View unanswered posts | View active topics It is currently Sun Sep 15, 2019 4:07 pm



Reply to topic  [ 630 posts ]  Go to page Previous  1 ... 16, 17, 18, 19, 20, 21, 22 ... 26  Next
VBA-M 
Author Message
Trooper
User avatar

Joined: Tue Jun 10, 2008 6:19 am
Posts: 369
Location: Australia
Reply with quote
Post 
Overview
The Microsoft Visual C++ 2008 Redistributable Package (x86) installs runtime components of Visual C++ Libraries required to run applications developed with Visual C++ on a computer that does not have Visual C++ 2008 installed.

System Requirements
Supported Operating Systems: Windows 2000 Service Pack 4; Windows Server 2003; Windows Vista; Windows XP
Required Software:
o Windows Installer 3.0 Windows Installer 3.1 or later is recommended.
Disk Space Requirements: 6 MB (x86)


Your problem evades me.

_________________
Image
VBA-M Forum, NGOHQ


Fri Aug 15, 2008 6:01 pm
Profile ICQ YIM WWW
ZSNES Developer
ZSNES Developer

Joined: Tue Dec 28, 2004 6:47 am
Posts: 6747
Reply with quote
Post 
Quote:
The Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) installs runtime components of Visual C++ Libraries required to run applications developed with Visual C++ SP1 on a computer that does not have Visual C++ 2008 SP1 installed.

System Requirements
Supported Operating Systems: Windows Server 2003; Windows Server 2008; Windows Vista; Windows XP

Minimum: 6 MB (x86)

Required Software: Windows Installer 3.0 Windows Installer 3.1 or later is recommended.


VBA-M Readme wrote:
Microsoft Visual C++ 2008 SP1 Redistributable Package (x86):
http://www.microsoft.com/downloads/deta ... layLang=en


Let me know when you've paid attention to your own documentation.

_________________
Continuing FF4 Research...


Fri Aug 15, 2008 7:19 pm
Profile
Trooper
User avatar

Joined: Tue Jun 10, 2008 6:19 am
Posts: 369
Location: Australia
Reply with quote
Post 
VBA-M works fine on the non sp1 version as far as i've seen.

you can just download the missing dll's and drop them in the folder anyway.


Quote:
Bugs fixed in MFC in Visual Studio 2008 SP1

Hello, everyone. This is Pat Brenner. I’m an SDE on the Visual C++ Libraries team.

We’ve just released Visual Studio 2008 SP1, and it includes about 55 fixes to the MFC library. Many of these fixes are for the new features that were added in the Feature Pack, but others were bugs in the RTM version of Visual Studio 2008 that we have fixed. Here is a partial list of the issues that we addressed:

· Some accessibility issues in toolbar and ribbon components were fixed.

· Running MFC applications on Windows 2000 (with or without GDIPlus.dll) is supported.

_________________
Image
VBA-M Forum, NGOHQ


Fri Aug 15, 2008 7:35 pm
Profile ICQ YIM WWW
ZSNES Developer
ZSNES Developer

Joined: Tue Dec 28, 2004 6:47 am
Posts: 6747
Reply with quote
Post 
I'm having problems finding the dlls to work around this (but I'll eventually try downloading the redist and see if it'll be happy, though I don't recall if I have the required Windows Installer version).

In any case, it helps if that stuff is provided on your file server and/or provide a link to the non-SP1 distrubutable in the readme (or something along those lines) to make life easier. You can't assume everyone's just going to figure it out automatically. People read the readme after all (well, maybe not).

_________________
Continuing FF4 Research...


Fri Aug 15, 2008 7:40 pm
Profile
has wat u liek
User avatar

Joined: Tue Sep 11, 2007 2:54 pm
Posts: 559
Location: Banland.
Reply with quote
Post 
Quote:
VBA-M works fine on the non sp1 version as far as i've seen.


Err, squall, I think you need to check the SVN...Spacy upgraded to MSVS2008 SP1. As a result, targeted OSes changed, thanks to MS >.>

Quote:
I'm having problems finding the dlls to work around this (but I'll eventually try downloading the redist and see if it'll be happy, though I don't recall if I have the required Windows Installer version).

In any case, it helps if that stuff is provided on your file server and/or provide a link to the non-SP1 distrubutable in the readme (or something along those lines) to make life easier. You can't assume everyone's just going to figure it out automatically. People read the readme after all (well, maybe not).


Sorry about the issues you are having. :( I will try and upload the non SP1 redists when I can.


Fri Aug 15, 2008 11:37 pm
Profile
Trooper
User avatar

Joined: Tue Jun 10, 2008 6:19 am
Posts: 369
Location: Australia
Reply with quote
Post 
mudlord wrote:
Quote:
VBA-M works fine on the non sp1 version as far as i've seen.


Err, squall, I think you need to check the SVN...Spacy upgraded to MSVS2008 SP1. As a result, targeted OSes changed, thanks to MS >.>

Quote:
I'm having problems finding the dlls to work around this (but I'll eventually try downloading the redist and see if it'll be happy, though I don't recall if I have the required Windows Installer version).

In any case, it helps if that stuff is provided on your file server and/or provide a link to the non-SP1 distrubutable in the readme (or something along those lines) to make life easier. You can't assume everyone's just going to figure it out automatically. People read the readme after all (well, maybe not).


Sorry about the issues you are having. :( I will try and upload the non SP1 redists when I can.


That explains things, i'll tell him to compile with support for Win2k

_________________
Image
VBA-M Forum, NGOHQ


Wed Aug 20, 2008 11:59 pm
Profile ICQ YIM WWW
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Reply with quote
Post 
I can't execute QT build 606, yes I updated the QT files too.

---------------------------
E:\Emulators\gameboy advance\VisualBoyAdvance.exe
---------------------------
E:\Emulators\gameboy advance\VisualBoyAdvance.exe



This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.


---------------------------
OK
---------------------------

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Mon Aug 25, 2008 1:28 pm
Profile WWW
has wat u liek
User avatar

Joined: Tue Sep 11, 2007 2:54 pm
Posts: 559
Location: Banland.
Reply with quote
Post 
MSVC2008 SP1 files you need in that case.

From now on, we will use non SP1. Saves all the hassles Deathlike2 and co are having.


Tue Aug 26, 2008 1:15 am
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Reply with quote
Post 
http://vba-m.ngemu.com/vbam/vbacompiles ... ance634.7z
Fails to run for me, I have tried the included DLL files And the ones found in the same spot on the site.

Quote:
---------------------------
E:\Emulators\gameboy advance\VisualBoyAdvance.exe
---------------------------
E:\Emulators\gameboy advance\VisualBoyAdvance.exe



This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.


---------------------------
OK
---------------------------

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Thu Aug 28, 2008 12:43 pm
Profile WWW
ZSNES Developer
ZSNES Developer

Joined: Tue Dec 28, 2004 6:47 am
Posts: 6747
Reply with quote
Post 
franpa, I have zero idea how you even get those errors. A screenshot would be better served.. unless that's a log. Even then... there's something probably wrong with your setup... maybe you should reinstall DX... but it seems like a bigger problem at work.

Start here: http://tinyurl.com/63jo8z

mudlord, it's still looking for the new stuff (mfc90.dll and probably some more).

_________________
Continuing FF4 Research...


Thu Aug 28, 2008 2:17 pm
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Reply with quote
Post 
Image

The DLL files in the pic are currently the ones provided in DLL.ZIP. yes I did try the ones included with VBA-M but theres no difference in the outcome.

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Thu Aug 28, 2008 3:03 pm
Profile WWW
Zealot
User avatar

Joined: Wed Jul 28, 2004 3:31 am
Posts: 1140
Reply with quote
Post 
I can get the MFC build to run just fine, but for some reason, the Qt build crashes in ATI's OpenGL module.

Image Image Image

I'll try updating my drivers a little later and see if that fixes the problem.


Thu Aug 28, 2008 8:46 pm
Profile WWW
Rookie

Joined: Wed Jul 04, 2007 9:21 pm
Posts: 28
Reply with quote
Post 
I recieve the same error message as franpa. Build 589 is the last one to work properly for me. Windows XP SP3, everything up-to-date.


Sat Aug 30, 2008 12:11 pm
Profile
New Member

Joined: Mon Jan 07, 2008 2:44 am
Posts: 3
Reply with quote
Post 
I had the same error as franpa and escapee. Try installing the Visual C++ 2008 redist. That solved the problem for me.

link


Thu Sep 04, 2008 3:36 am
Profile
has wat u liek
User avatar

Joined: Tue Sep 11, 2007 2:54 pm
Posts: 559
Location: Banland.
Reply with quote
Post 
Quote:
but for some reason, the Qt build crashes in ATI's OpenGL module.


For some reason, in my head, those 2 words bring a whole world of hurt. Though, it could be something simple on our end, like with mixing QPainter and OGL.

Quote:
mudlord, it's still looking for the new stuff (mfc90.dll and probably some more).


Checked out the latest stuff? If not, I might have to make matters into my own hands.


Thu Sep 04, 2008 3:59 am
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Reply with quote
Post 
Yea deathlike, I did update directX, no difference. I looked at the eventlogs and found it was indeed refrencing VC90.CRT which I don't have.

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Thu Sep 04, 2008 3:03 pm
Profile WWW
Official tech support dood

Joined: Wed Jan 25, 2006 7:57 am
Posts: 2085
Reply with quote
Post 
franpa wrote:
Yea deathlike, I did update directX, no difference. I looked at the eventlogs and found it was indeed refrencing VC90.CRT which I don't have.

Simea wrote:
I had the same error as franpa and escapee. Try installing the Visual C++ 2008 redist. That solved the problem for me.

link

_________________
Why yes, my shift key *IS* broken.


Thu Sep 04, 2008 4:29 pm
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Reply with quote
Post 
Do you think I can be bothered downloading/installing something from microsoft that is hundreds of megabytes in size, just for one program?

is what I would be saying, but I checked the link and it is only 4mb, and it indeed worked :)

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Fri Sep 05, 2008 2:58 am
Profile WWW
"God"

Joined: Tue Jul 27, 2004 11:24 pm
Posts: 1128
Reply with quote
Post 
hundreds of megs? think again franpa

do you even bother following links... Why do I ask, you don't.

_________________
Does [Kevin] Smith masturbate with steel wool too?

- Yes, but don’t change the subject.


Fri Sep 05, 2008 3:05 am
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Reply with quote
Post 
I was thinking the "redistribution" version was the whole thing and not just the runtime stuff. Like the Direct X bi-monthly updates and the DirectX redistribution pack.

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Fri Sep 05, 2008 3:08 am
Profile WWW
has wat u liek
User avatar

Joined: Tue Sep 11, 2007 2:54 pm
Posts: 559
Location: Banland.
Reply with quote
Post 
*facepalm*

You mean the SDK, which is several hundred MB.

You only need the redist or the web updater on our server.


Fri Sep 05, 2008 6:00 am
Profile
has wat u liek
User avatar

Joined: Tue Sep 11, 2007 2:54 pm
Posts: 559
Location: Banland.
Reply with quote
Post 
new Windows SVN compile out, for those that care.


Mon Sep 08, 2008 2:49 am
Profile
ZSNES Developer
ZSNES Developer

Joined: Tue Dec 28, 2004 6:47 am
Posts: 6747
Reply with quote
Post 
The readme still links to the SP1 redist... which is not useful.

_________________
Continuing FF4 Research...


Fri Sep 12, 2008 8:29 pm
Profile
has wat u liek
User avatar

Joined: Tue Sep 11, 2007 2:54 pm
Posts: 559
Location: Banland.
Reply with quote
Post 
Stuff should be statically linked.

In other news, I quit working on this thing. I know spacy, chrono, blargg, nach, jonas and co will do a good job. chrono made some patches for UPS/PPF support if people even give a fuck for this code. plus fixed some memory leaks in the core. So, if someone can remove my "VBA Developer" tag, that would be great.

Thanks.


Sun Sep 14, 2008 6:38 am
Profile
Locksmith of Hyrule
User avatar

Joined: Sun Aug 08, 2004 7:49 am
Posts: 3634
Location: 255.255.255.255
Reply with quote
Post 
No problem, for the time being I guess this can be crunched, till a new head dev steps in.

It's been a good run.

also sorry to hear that Mudlord. Hope you'll be able to come back one day.

_________________
Image
<Nach> so why don't the two of you get your own room and leave us alone with this stupidity of yours?
NSRT here.


Sun Sep 14, 2008 6:44 am
Profile YIM WWW
Display posts from previous:  Sort by  
Reply to topic   [ 630 posts ]  Go to page Previous  1 ... 16, 17, 18, 19, 20, 21, 22 ... 26  Next

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.