View unanswered posts | View active topics It is currently Sun Sep 22, 2019 12:05 pm



Reply to topic  [ 3 posts ] 
1.51 x64 audio crackling with Win8.1 x64 
Author Message
New Member

Joined: Sat Dec 27, 2014 6:41 am
Posts: 1
Reply with quote
Post 1.51 x64 audio crackling with Win8.1 x64
Here's my specs:
Power supply Corsair AX1500i
Surge protector Rosewill RHSP-13003 (and have my case grounded with a secondary copper wire)
CPU A10-7850K AD785KXBJABOX
RAM Team Xtreem LV 16GB TXD316G2400HC10QDC01
Video Card GTX 780 Ti Classified
Motherboard ASRock A88X FM2+ Extreme6+
OS Windows 8.1 OEM
Legacy OS Windows XP Professional 32-bit
Monitor ASUS VG248QE
-------------
I'm trying to use a ROM of Dragon Quest (Japan) translated by RPGOne. I'm using v1.51. I'm getting crackling and popping regardless of the Hz setting. SNES9x is doing the same thing (tried one of their dev test builds, too); changed the codec in ZSNES but it didn't have any effect, buffer size, monitor refresh rate, audio sampling rate in Windows, tried the different interpolators, turned on and off V-sync; and moved the installation location of zsnes (btw i'm too stupid to learn the name of the emulator). It might be a latency thing; the Realtek chip supports up to 192kHz, and my specs are all modern. What do?


Sat Dec 27, 2014 7:05 am
Profile
Trooper
User avatar

Joined: Tue Jan 08, 2013 12:24 pm
Posts: 417
Reply with quote
Post Re: 1.51 x64 audio crackling with Win8.1 x64
Stick with 9x 1.53, go to sound settings and switch the sound driver to XAudio2. Directsound gave me tons of crackling but XA2 is much, much cleaner. Changing the sound driver to XA2 made the most difference for me, but if there's still crackling, go to video settings and make sure "hi-resolution support" and "blend hi-res images" are both unchecked. I'm not sure if any of the test builds resolve the sound issues; it's a very common problem.

ZSNES is wonky in Win8/8.1(and any 64-bit OS iirc) and there's no way that I know of to make it run properly.


Fri Mar 27, 2015 10:45 pm
Profile
Rookie

Joined: Thu Aug 27, 2015 1:56 am
Posts: 13
Reply with quote
Post Re: 1.51 x64 audio crackling with Win8.1 x64
If it is a latency thing, try using either DPC Latency Checker or Latencymon to determine the real cause. It could be the outdated network drivers (WiFi/WLAN, or ethernet/LAN) that could be causing unusually high latency. Sounds weird but updating the network drivers and sound card drivers may help.

Try playing zsnes 1.51 on a PC w/ no internet connection active (deactivate or disable network drivers)


Thu Oct 01, 2015 6:01 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.