View unanswered posts | View active topics It is currently Sat Sep 21, 2019 4:56 am



Reply to topic  [ 2 posts ] 
Mouse/Keyboard don't work when controller is plugged in 
Author Message
New Member

Joined: Fri Mar 04, 2016 8:01 pm
Posts: 1
Reply with quote
Post Mouse/Keyboard don't work when controller is plugged in
Hello!

First of all, this being the ZSNES board, I just want to say that anyone who went into the design of this program, you have my sincere gratitude. I've been enjoying Mario ROM hacks for years, and playing them with friends even! ZSNES not only has brought nostalgic good-vibes for me, but even allowed me to go on some new adventures!

Anyways, to the problem (tl/dr at the bottom):

I somewhat recently got a new laptop that runs Windows 10. This, along with my instance to play with my laptop hooked up to my TV, has created a whole host of problems with ZSNES, but I've been able to work through all of them up to this point. And I don't even think this problem is related.

Out of the blue one day, the mouse, and most of the keyboard, wouldn't respond when I started up ZSNES. I eventually went into the config file and set it so that the controller could work the menu, but this leaves me no safe option for closing the program (not to mention it takes away my ability to use my very precious save states with the f2 and f4 keys!)

So I sort of pounded my head on a wall for awhile and gave up. Today, on a whim, I started up ZSNES, and the mouse and keyboard were working perfectly! So I backed out of the emulator, plugged in my controller, and restarted. Alas, the mouse and keyboard stopped working. So I repeated that process a few times.

It seems that the controller is overriding the mouse/keyboard out-of-the-blue, after no modifications from me to the program and it successfully working previously.

The controller I'm using is an XBox 1 controller hooked through a USB cable, if that helps. But I don't think it's the controller, since this combination was working fine just a few days ago.


Fri Mar 04, 2016 8:10 pm
Profile
Official tech support dood

Joined: Wed Jan 25, 2006 7:57 am
Posts: 2086
Reply with quote
Post Re: Mouse/Keyboard don't work when controller is plugged in
i'd suspect one of the following:
  • the driver or a utility for the xbox controller was updated and its behavior changed
  • a keymapping utility was installed/updated/reconfigured

_________________
Why yes, my shift key *IS* broken.


Sat Mar 05, 2016 4:34 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.