View unanswered posts | View active topics It is currently Tue Dec 10, 2019 3:35 pm



This topic is locked, you cannot edit posts or make further replies.  [ 504 posts ]  Go to page Previous  1 ... 5, 6, 7, 8, 9, 10, 11 ... 21  Next
(old) ZMV to AVI video conversion [[archive me]] 
Author Message
ZSNES Developer
ZSNES Developer
User avatar

Joined: Tue Jul 27, 2004 10:54 pm
Posts: 3902
Location: Solar powered park bench
Post 
Welcome to page 8.

To record a video you need one of the latest work in progress builds of ZSNES. Get them here: http://zsnes.ipherswipsite.com/

You will need a copy of mencoder. For Windows users, I recommend getting mencoder here: http://oss.netfarm.it/mplayer-win32.php
Place mencoder.exe in the same location as zsnesw.exe, you do not need any codecs or other movie programs installed.
Linux users, having mencoder in your path is fine.

If you want to compress the outputted audio, or compress it before it goes into the video as opposed to during, you will need a copy of LAME.
If you use Windows, you must get LAME from here: http://geocities.com/joecool22us/lame.zip
Any other copy of LAME for Windows will not work due to a bug in LAME.

Before you are able to dump an AVI, you must have recorded a movie first, it converts movies, it does not just dump video on the fly.

To play back movies, you'll either need the proper codecs or a video player with built in decoding of the video mode you selected.
I recommend getting mplayer which decodes anything created with mencoder. For Windows, you can get mplayer here: http://oss.netfarm.it/mplayer-win32.php You can download the GUI version.

Advanced users can edit zmovie.cfg and tweak the settings if they want, and even use something other than mencoder and LAME as long as it supports encoding via stdin and you set it up properly.

________
Remember, mencoder from the site I linked offers bleeding edge x264 encoding (builds are generally never more than 3 weeks old). Most H.264 decoders aren't up to date.

MPlayer, MEncoder, and VLC though use up to date copies of FFMPEG and can decode new stuff too.

_________________
May 9 2007 - NSRT 3.4, now with lots of hashing and even more accurate information! Go download it.
_____________
Insane Coding


Last edited by Nach on Sat Mar 29, 2008 7:44 pm, edited 2 times in total.



Wed Mar 08, 2006 1:14 pm
Profile WWW
Rookie

Joined: Tue Mar 07, 2006 12:12 pm
Posts: 14
Post 
http://ffdshow.faireal.org/#ffdshow

Installed and it plays perectly in MPC.


Wed Mar 08, 2006 1:14 pm
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Post 
so you also experienced problems with mpc and these video dumps?

ffdshow screwed up m43 encoded movies on my pc... so i dont use it. (m43 i think is mp4)

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Wed Mar 08, 2006 1:15 pm
Profile WWW
Rookie

Joined: Tue Mar 07, 2006 12:12 pm
Posts: 14
Post 
I don't normally use it (I use VLC for all my video playback) but I thought I'd give it a try given the problems that you've had.

No doubt it is as Nach has said - your installed codecs (which MPC uses and VLC doesn't) aren't up to date enough to play the files correctly.

If you're *really* opposed to using updated ffdshow stuff, maybe you could try an older version of mencoder? I wouldn't really expect everyone else to follow suit though ;p And I suspect Nach will still recommend the latest mencoder (as would I).


Wed Mar 08, 2006 1:23 pm
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Post 
i may stick to vlc (for h264 and x264 files)... as it fixes desyncing in the avi files. (some stuff was being skipped thus causing the video to go haywire but vlc plays it fine)

ffdshow replaced my m43 codec with a screwed one so most programs displayed it incorrectly... k-lite mega pack doesnt have this issue so i use it instead.

- thanks nach, aerkeron and grinvader... for all your help on this issue.

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Wed Mar 08, 2006 1:25 pm
Profile WWW
Hazed
User avatar

Joined: Sun Feb 26, 2006 8:08 am
Posts: 79
Post Thanks
I download the zsnesw-mov.zip and replace the old one with this.

Back to normal on the "dump movie" and fixs. :wink:

Btw: I forgotting to download the mplayer with the font. I download the mplayer-p4-cvs-20060306.zip and fixs the font reading problem.


Wed Mar 08, 2006 3:54 pm
Profile
Mugwump
User avatar

Joined: Fri Jul 30, 2004 9:05 pm
Posts: 824
Post 
VLC is the only player that plays these back for me.


Wed Mar 08, 2006 4:07 pm
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Post 
thats correct herzog... must be a slightly newer format of the h264 codec encoder... meaning newer decoder required to watch them.

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Wed Mar 08, 2006 11:30 pm
Profile WWW
16-bit Corpse | Nyoron~
User avatar

Joined: Sun Aug 01, 2004 7:14 pm
Posts: 3534
Location: Nokia Land
Post 
h264, x264, etc. play fine in ZoomPlayer too. Love it. BSPlayer to a degree, but I've had troubles getting subtitles to work.

_________________
whicker: franpa is grammatically correct, and he still gets ripped on?
sweener2001: Grammatically correct this one time? sure. every other time? no. does that give him a right? not really.
Image


Wed Mar 08, 2006 11:43 pm
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Post 
when buziol games get there videos back online... you can see that they dont play correct in vlc... yet they play fine in mpc with k-lite mega codec pack.

buziol games videos are recorded in m43 format.

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Thu Mar 09, 2006 12:37 am
Profile WWW
Rookie

Joined: Wed Dec 21, 2005 3:54 am
Posts: 14
Post 
I'm getting a "Broken Pipe" error when trying to dump video. Anyone else?


Fri Mar 10, 2006 7:32 am
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Post 
broken pipe! what the hell is that... never ever heard of such an error message.

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Fri Mar 10, 2006 7:57 am
Profile WWW
ZSNES Developer
ZSNES Developer

Joined: Tue Dec 28, 2004 6:47 am
Posts: 6747
Post 
franpa_9 wrote:
broken pipe! what the hell is that... never ever heard of such an error message.


This is a error message found on a Linux system (he's referring to ZSNES's SDL port).

_________________
Continuing FF4 Research...


Fri Mar 10, 2006 8:02 am
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Post 
oh... thanks... goes to show i never used linux.

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Fri Mar 10, 2006 8:09 am
Profile WWW
ZSNES Developer
ZSNES Developer
User avatar

Joined: Tue Jul 27, 2004 10:54 pm
Posts: 3902
Location: Solar powered park bench
Post 
eyebrowsoffire wrote:
I'm getting a "Broken Pipe" error when trying to dump video. Anyone else?

Latest CVS?

You have mencoder? LAME?
Which options did you check?

_________________
May 9 2007 - NSRT 3.4, now with lots of hashing and even more accurate information! Go download it.
_____________
Insane Coding


Fri Mar 10, 2006 12:02 pm
Profile WWW
Rookie

Joined: Wed Dec 21, 2005 3:54 am
Posts: 14
Post 
Nach wrote:
eyebrowsoffire wrote:
I'm getting a "Broken Pipe" error when trying to dump video. Anyone else?

Latest CVS?

You have mencoder? LAME?
Which options did you check?


Hmmm....CVS... I have the latest mencoder rpm package for Fedora Core 4. I guess I'll go install CVS. Thanks.


Sat Mar 11, 2006 12:02 am
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Post 
just had to say this... latest version of media player classic has solved all issues ive experienced in playing movies. (it now plays movies made by zsnes)

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Mon Mar 13, 2006 1:00 pm
Profile WWW
Hazed
User avatar

Joined: Sun Feb 26, 2006 8:08 am
Posts: 79
Post Here is another mplayer website.
I wonder it is bug free? http://www.mplayerhq.hu/design7/news.html

_________________
"Zsnes is the best one there is." :)


Mon Mar 13, 2006 1:55 pm
Profile
ZSNES Developer
ZSNES Developer
User avatar

Joined: Tue Jul 27, 2004 10:54 pm
Posts: 3902
Location: Solar powered park bench
Post 
Don't know what happened to ipher, we could use an update here.

http://nsrt.edgeemu.com/zsnesw-mov.zip

I made it easier to figure out the audio options.
I also made the default compress AVIs better (delete zmovie.cfg to get defaults).

Let me know how it is.

_________________
May 9 2007 - NSRT 3.4, now with lots of hashing and even more accurate information! Go download it.
_____________
Insane Coding


Fri Mar 17, 2006 3:46 am
Profile WWW
Hazed
User avatar

Joined: Sun Feb 26, 2006 8:08 am
Posts: 79
Post Re:
Thanks for this wip release.

Nach, can you tell me why the sounds are low on ZSNES and high on the AVI? I had to turn down my WinAmp alittle which it is turn all the way up. ZSNES is max at 100%. Just wondering.

_________________
"Zsnes is the best one there is." :)


Fri Mar 17, 2006 4:15 am
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Post 
thanks... makes it a ton more obviouse and easier to manage.

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Fri Mar 17, 2006 5:02 am
Profile WWW
Regular
User avatar

Joined: Mon Aug 15, 2005 2:15 pm
Posts: 207
Post Re:
KingHanco wrote:
Thanks for this wip release.

Nach, can you tell me why the sounds are low on ZSNES and high on the AVI? I had to turn down my WinAmp alittle which it is turn all the way up. ZSNES is max at 100%. Just wondering.


Check your advanced volume controls in windows.


Fri Mar 17, 2006 11:49 am
Profile
ZSNES Developer
ZSNES Developer
User avatar

Joined: Tue Jul 27, 2004 10:54 pm
Posts: 3902
Location: Solar powered park bench
Post Re:
KingHanco wrote:
Thanks for this wip release.

Nach, can you tell me why the sounds are low on ZSNES and high on the AVI? I had to turn down my WinAmp alittle which it is turn all the way up. ZSNES is max at 100%. Just wondering.

Don't know about volume issues, however ZSNESW and ZSNES SDL do not output thier sound correctly. WAV writing does have proper output.

franpa_9 wrote:
thanks... makes it a ton more obviouse and easier to manage.

No problem, I was hoping that'd be the case.


Anyone notice an improvement on file sizes when using XviD or x264 with new defaults?

_________________
May 9 2007 - NSRT 3.4, now with lots of hashing and even more accurate information! Go download it.
_____________
Insane Coding


Fri Mar 17, 2006 11:55 am
Profile WWW
Hazed
User avatar

Joined: Sun Feb 26, 2006 8:08 am
Posts: 79
Post Re:
Hyos wrote:
KingHanco wrote:
Thanks for this wip release.

Nach, can you tell me why the sounds are low on ZSNES and high on the AVI? I had to turn down my WinAmp alittle which it is turn all the way up. ZSNES is max at 100%. Just wondering.


Check your advanced volume controls in windows.


I have those max out long time ago. No need to check.

Image

Nach wrote:
Don't know about volume issues, however ZSNESW and ZSNES SDL do not output thier sound correctly. WAV writing does have proper output.


Ok.

_________________
"Zsnes is the best one there is." :)


Fri Mar 17, 2006 4:47 pm
Profile
ZSNES Developer
ZSNES Developer
User avatar

Joined: Tue Jul 27, 2004 10:54 pm
Posts: 3902
Location: Solar powered park bench
Post 
Anyone see how much smaller AVIs are with the new zmovie.cfg defaults now?

BTW, I notice that if you download ffdshow, and in it's decoder options, you set H264 decoding to ffdshow, Windows Media Player, Virtual Dub, and other VFW codec using programs will decode x264 encoded movies properly.

_________________
May 9 2007 - NSRT 3.4, now with lots of hashing and even more accurate information! Go download it.
_____________
Insane Coding


Sun Mar 19, 2006 12:26 am
Profile WWW
Display posts from previous:  Sort by  
This topic is locked, you cannot edit posts or make further replies.   [ 504 posts ]  Go to page Previous  1 ... 5, 6, 7, 8, 9, 10, 11 ... 21  Next

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.