View unanswered posts | View active topics It is currently Tue Sep 17, 2019 2:51 am



This topic is locked, you cannot edit posts or make further replies.  [ 5 posts ] 
bsnes sound problem 
Author Message
Reply with quote
Post bsnes sound problem
Hoping this is the right place to post, as I think it's a problem with my settings, rather than an emulation bug...

In previous versions of bsnes (maybe .036 or so), on most games most of the time, the sound stayed smooth (only choppy in certain instances, and for less than a second). I was also running it with a little under 512MB RAM at the time. Now since about... not sure, but definitely .038 and the current .039, no matter what I change bsnes's sound/video settings to, the sound in every game is choppy all the time. I have no idea what's wrong or how to fix it. And I got my RAM upgraded to 2GB at Christmas, too.

[quote=dxdiag]Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.080814-1236)
Processor: Intel(R) Pentium(R) 4 CPU 2.80GHz (2 CPUs)
Memory: 2046MB RAM
DirectX Version: DirectX 9.0c (4.09.0000.0904)[/quote]

I couldn't see anything in the FAQ about how much system info to post, so there's that. A forum search didn't really help me out either, because pretty much every solution I saw was for Linux users only. I'm thinking that using an older version of bsnes would obviously fix this, but I'd really like to be able to try the latest version instead of having to forever stick with an outdated one. Please help?


Fri Jan 23, 2009 8:19 pm
Reply with quote
Post 
RAM's not a problem, it doesn't use more than ~32-48MB. CPU integer performance is the only real bottleneck.

And unfortunately, a Pentium IV probably isn't fast enough for the current builds. You'd want at least a 1.6GHz Core processor :(

Try settings->emu speed-> and uncheck sync video, sync audio. If your framerate isn't getting much over 60fps, then you won't have much luck getting clean sound.

v037 was definitely faster than v038, and v039 only got back ~80% of the speed lost. I'd say v017 was the fastest to date.

I'm sorry that it runs too slowly for you :(
If it's any consolation, I'm planning on one day making a fast version once I get the slow one to my liking.


Fri Jan 23, 2009 8:39 pm
Reply with quote
Post 
Quote:
If it's any consolation, I'm planning on one day making a fast version once I get the slow one to my liking.

Music to my ears. I've recently realized that I can no longer run every supported game at full speed on newer versions of bsnes. I use bsnes .037 quite happily.

I personally subscribe half-way between your way of thinking, and h4tred's way of thinking in terms of code-clarity/speed.


Fri Jan 23, 2009 9:13 pm
Hazed

Joined: Mon Dec 24, 2007 2:03 am
Posts: 51
Location: Russia
Reply with quote
Post 
Something happens to me too. All of sudden the "Sync audio" option dropped the bsnes performance for about 40-50%, enough to make it lag on BOTH sound cards i have (Creative X-Fi + Juli@).
Everything changes on my workstation at any time, and i do test byuu's wip sometimes including latest 0.038's but i guess this happens after video drivers update for the NVidia GF8600GTS chip. The strange thing it gave the same results for OpenGL, Direct3D, DirectDraw, GDI..
..and popped out at Christmas time :?

DxDiag wrote:
Operating System: Windows Vistaâ„¢ Ultimate (6.0, Build 6001) Service Pack 1 (6001.vistasp1_gdr.080917-1612)
Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ (2 CPUs), ~2.2GHz
Memory: 8190MB RAM
DirectX Version: DirectX 10


But! :shock: for now bsnes v0.039 is going as smooth as before, for about 80-100 fps, and steady 60 fps for NTSC emulation. Can't get what was wrong to it and why it do not like Christmas.

@Rat
Try to disable the "Sync audio" option, but instead turn on the "Sync video" option. It do give you a bit sandy, crisp sound but still playable timings.

_________________
quake2xp audio engineer


Fri Jan 23, 2009 10:32 pm
Profile WWW
Reply with quote
Post 
Thanks for the help. .037 plays games just as well without the sound problems. I'll still try out new versions as they come out, because I love this emulator. :D


Tue Jan 27, 2009 5:48 am
Display posts from previous:  Sort by  
This topic is locked, you cannot edit posts or make further replies.   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.