View unanswered posts | View active topics It is currently Fri Dec 06, 2019 11:41 pm



This topic is locked, you cannot edit posts or make further replies.  [ 180 posts ]  Go to page Previous  1 ... 4, 5, 6, 7, 8
bsnes v0.041 released 
Author Message
Veteran

Joined: Wed Aug 04, 2004 5:43 pm
Posts: 861
Location: Sloop
Post 
byuu wrote:
Could you elaborate on that?


My 3rd post of Pg.2, I made a suggestion that you agreed to. I think you may have forgotten about it.

Quote:
Yeah, but then you can already tell what you're on from the left-hand listbox.


Not if it's been minimized, anyway.


Sun Mar 29, 2009 11:27 pm
Profile
Regular
User avatar

Joined: Tue Mar 07, 2006 10:32 am
Posts: 347
Location: The Netherlands
Post 
Got something odd just now: I changed my controller from the default drivers to drivers from the manufacturer, and when I used 'Assign All' in bsnes the 'this controller must be calibrated' box popped up only -after- I'd already assigned 'up'. I'd already tested it successfully with the stock drivers before then, and button assignment still worked regardless.


Mon Mar 30, 2009 12:13 am
Profile
Post 
Verdauga Greeneyes wrote:
Got something odd just now: I changed my controller from the default drivers to drivers from the manufacturer, and when I used 'Assign All' in bsnes the 'this controller must be calibrated' box popped up only -after- I'd already assigned 'up'. I'd already tested it successfully with the stock drivers before then, and button assignment still worked regardless.


It's because your driver sent an analog motion signal after you pressed up. Most likely it was reporting all neutral values until any button was pressed, and up on your controller wasn't actually an analog input but a POV hat.


Mon Mar 30, 2009 2:33 am
Veteran
User avatar

Joined: Thu Feb 03, 2005 8:18 pm
Posts: 768
Post 
byuu wrote:
Okay then, if everyone possible could test this quickly, I can post a new release tonight. Especially the input mapping, and especially there for gamepads / controllers.

When I open the WIP, this is all I see:
http://www.endoftransmission.net/pics/bsnes_error.png
I freezes the entire screen. I can move the mouse, but I can't click on anything in or outside the black box. No keyboard response or mouse click response. I can still open up the Task Manager and kill the process though.
I'm on Vista SP1.

_________________
Official ZSNES Docs | NSRT Guide | Using a Wiimote w/ emulators


Mon Mar 30, 2009 3:59 am
Profile WWW
Post 
Kiddo, you were right about there being a BS-X bug. Actually there were two, heh.

On Windows, it wasn't copying the BIOS name over correctly; and after that, it was throwing errors when you went to boot the cart from the town menu. That took me nearly three hours to track down. Apparently, I changed virtual unsigned Memory::size() to virtual unsigned Memory::size() const, but didn't update BSXFlash::size() to const as well, so it was ignoring it and using the base type, returning 0 for the cart size, which broke mapping.

Jipcy, sorry. I have no idea why that's happening. bsnes isn't a raster-only UI, so there's absolutely no reason you shouldn't at least see the title bars. I hope it's automagically fixed in the new official release, or you may be out of luck :/

I'd say try deleting the bsnes.cfg file (start->run->%appdata% <enter>, delete .bsnes folder). Failing that, set system.video/audio/input to "None" to rule out driver issues. Failing that, re-install DirectX 9.0c run-time. Failing that, ... I hope you know how to program.


Mon Mar 30, 2009 10:33 am
Display posts from previous:  Sort by  
This topic is locked, you cannot edit posts or make further replies.   [ 180 posts ]  Go to page Previous  1 ... 4, 5, 6, 7, 8

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.