View unanswered posts | View active topics It is currently Fri Mar 24, 2017 6:53 pm



Reply to topic  [ 10 posts ] 
151 crashes on full screen 
Author Message
Reply with quote
Post 151 crashes on full screen
i dunno why its doing this, it was fine for like an hour, then i paused it and went and checked my mail, i came back and ever since it just crashes

i deleted all files except roms and saves, and reloaded zsnes, ut still it just crashes if i go to full screen, when i say crash i mean it minimizes the window everytime i maximize it

my specs

win xp pro sp2
19" non-wide monitor
intel setup

thanks


Tue Jun 03, 2008 12:20 am
ZSNES Developer
ZSNES Developer

Joined: Tue Dec 28, 2004 6:47 am
Posts: 6747
Reply with quote
Post 
I'm not sure how you "paused it". Try deleting zsnesw.cfg and/or rebooting your comp.

_________________
Continuing FF4 Research...


Tue Jun 03, 2008 12:33 am
Profile
Reply with quote
Post 
i paused it by pressing the ESX buton

ive tried that a few times already


Tue Jun 03, 2008 12:36 am
ZSNES Developer
ZSNES Developer

Joined: Tue Dec 28, 2004 6:47 am
Posts: 6747
Reply with quote
Post 
Well, I dunno what happened then. Try disabling/reenabling DDraw in Dxdiag.

_________________
Continuing FF4 Research...


Tue Jun 03, 2008 12:38 am
Profile
New Member

Joined: Sun Jul 13, 2008 10:25 pm
Posts: 3
Reply with quote
Post 
Same thing here, but 1.51 worked on my old PC. Any full-screen resolution causes the emulator to minimize. I can also confirm this occurs in 1.50 as well.

BTW, I'm using a 9800 GX2 as my main GPU. Ill try setting ZSNES to run on only 1 GPU, and see if that fixes the problem.


Sun Jul 13, 2008 10:27 pm
Profile
New Member

Joined: Sun Jul 13, 2008 10:25 pm
Posts: 3
Reply with quote
Post 
Update: 1.42 also fails, and its NOT an SLI issue.

I'm also getting a Direct Draw error, it dissappears fast though:

idirectDraw7: setcooperativelevel failed


And yes, dxdiag says everything is all right.

EDIT

Turning off and turning all acceleration options back on failed to, as did re-installing Direct X.

EDIT 2

Re-installing Direct X did make the setcooperativelevel failed go away at least, but ZSNES still minimized when it goes to full-screen.

EDIT 3

SNES9x 1.51 and 1.50 also fail with full-screen mode. Emulator auto-minimizes


EDIT 4: ISSUE FIXED

Control Panel -> Display -> Settings -> Advanced -> Troubleshoot -> Uncheck "Enable Write Combining"

Write Combining speeds up the writing to the display, and was the issue causing the full-screen errors. Disabling and restarting windows should fix the problem

EDIT 5:

Another restart broke it again. I'm looking into it

EDIT 6: (Fixed for now) (im so banned :D)

16 bit color mode MUST be enabled. That seems to have done the trick...


Sun Jul 13, 2008 10:39 pm
Profile
ZSNES Shake Shake Prinny
User avatar

Joined: Wed Jul 28, 2004 4:15 pm
Posts: 5613
Location: PAL50, dood !
Reply with quote
Post 
Editing your posts several times is not a banning offense. It's not even an offense, since it's the right thing(tm).

_________________
皆黙って俺について来い!!
Code:
<jmr> bsnes has the most accurate wiki page but it takes forever to load (or something)

Pantheon: Gideon Zhi | CaitSith2 | Nach | kode54


Mon Jul 14, 2008 12:28 pm
Profile
New Member

Joined: Sun Jul 13, 2008 10:25 pm
Posts: 3
Reply with quote
Post 
grinvader wrote:
Editing your posts several times is not a banning offense. It's not even an offense, since it's the right thing(tm).


Hence, the smiley :D

Still, OP, try running in 16 bit color mode and see if the issue persists; that seems to be the root cause anyway...


Mon Jul 14, 2008 11:51 pm
Profile
New Member

Joined: Thu Dec 08, 2016 9:16 pm
Posts: 1
Reply with quote
Post Re:
gamerk316 wrote:
grinvader wrote:
Editing your posts several times is not a banning offense. It's not even an offense, since it's the right thing(tm).


Hence, the smiley :D

Still, OP, try running in 16 bit color mode and see if the issue persists; that seems to be the root cause anyway...


Thank you so much, this glitch was happening to me too and I couldn't pinpoint the issue anywhere!


Thu Dec 08, 2016 9:18 pm
Profile
New Member

Joined: Thu Feb 16, 2017 9:23 pm
Posts: 1
Reply with quote
Post Re: 151 crashes on full screen
I'm having this problem, too, right out of the box. I'm running Windows 8, in case that's relevant.


Thu Feb 16, 2017 9:29 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.