View unanswered posts | View active topics It is currently Sun Jan 20, 2019 12:51 am



Reply to topic  [ 16 posts ] 
newbie problems with configuring usb gamepad 
Author Message
New Member

Joined: Wed Jan 13, 2010 9:21 pm
Posts: 6
Reply with quote
Post newbie problems with configuring usb gamepad
hey there, so i've got this Image gamepad, worked fine on resident evil pc version a few weeks ago (i don't have it installed anymore)

now i tried to configure it to play super mario :D (game works fine on keyboard) but nothing happens?!

problem is that i am not really that much in computer games so i don't know much about emulators and stuff...

the gamepad is recognized when i go to control panel/game controllers (when plugging in out it appears/disappears) aldough when i go to properties i cant do anything there (should i even be able to??)


if someone knows the answers for my problems feel free to post :)

and last, sorry for spelling and grammatic, english ain't my language :D


Wed Jan 13, 2010 9:33 pm
Profile
16-bit Corpse | Nyoron~
User avatar

Joined: Sun Aug 01, 2004 7:14 pm
Posts: 3534
Location: Nokia Land
Reply with quote
Post 
Click Config --> Input #1. Make sure Keyboard/Gamepad is selected, click Set. Follow the prompts.

_________________
whicker: franpa is grammatically correct, and he still gets ripped on?
sweener2001: Grammatically correct this one time? sure. every other time? no. does that give him a right? not really.
Image


Wed Jan 13, 2010 9:35 pm
Profile
New Member

Joined: Wed Jan 13, 2010 9:21 pm
Posts: 6
Reply with quote
Post 
tried,

config/input1/selecting keyped/joystick/clicking set keys/ - he asks me to press buttons for up, down, left, right... but no mather what i press on tha gamepad nothing happens. with keyboard it's still no problem


Wed Jan 13, 2010 9:40 pm
Profile
Official tech support dood

Joined: Wed Jan 25, 2006 7:57 am
Posts: 2075
Reply with quote
Post 
do you have the controller connected before you launch zsnes?

_________________
Why yes, my shift key *IS* broken.


Wed Jan 13, 2010 9:49 pm
Profile
New Member

Joined: Wed Jan 13, 2010 9:21 pm
Posts: 6
Reply with quote
Post 
of course,

question by the way: should i be able to do anything here?

Image

like i said the controller is being recognized when plugging in and out but on this menu i cant do nothing on any of the 3 tabs, is that supposed to be so?

and do i maybe need some addionional plug-ins add-on's for zsnes or something? like i said, i'm not really that much in the gaming scene just want to play super mario with a gamepad :D[/img]


Wed Jan 13, 2010 9:57 pm
Profile
Official tech support dood

Joined: Wed Jan 25, 2006 7:57 am
Posts: 2075
Reply with quote
Post 
yes, it should be working there. if it doesn't work there, it won't work anywhere else (including zsnes).

_________________
Why yes, my shift key *IS* broken.


Wed Jan 13, 2010 10:44 pm
Profile
New Member

Joined: Wed Jan 13, 2010 9:21 pm
Posts: 6
Reply with quote
Post 
and is there any way to make it work? like i said i used it a few weeks ago for a pc game and it worked, since than it was unused till i tried to get it work for super mario. It is recognized when plugged in and i can switch the red light via the mode button (the one that on a ps gamepad the analog button is)

also tried the troubleshoot function but that was useless...


Wed Jan 13, 2010 11:02 pm
Profile
Official tech support dood

Joined: Wed Jan 25, 2006 7:57 am
Posts: 2075
Reply with quote
Post 
try reinstalling the drivers

_________________
Why yes, my shift key *IS* broken.


Thu Jan 14, 2010 12:05 am
Profile
New Member

Joined: Wed Jan 13, 2010 9:21 pm
Posts: 6
Reply with quote
Post 
drivers reinstalled, still nothing, it appears on control panel/game controllers but tat's about it, cant adjust anything adn TILL CANT PLAY SUPER MARIO!!!!!!!!! :cry:


Sat Jan 16, 2010 12:59 pm
Profile
Buzzkill Gil

Joined: Wed Jan 12, 2005 7:14 pm
Posts: 4229
Reply with quote
Post 
Sounds broken to me.

_________________
Squall_Leonhart wrote:
Quote:
You have your 2s, 4s, 8s, 16s, 32s, 64s, and 128s(crash course in binary counting!). But no 1s.
DirectInput represents all bits, not just powers of 2 in an axis.


KHDownloads


Sat Jan 16, 2010 1:56 pm
Profile
Veteran

Joined: Fri Jan 21, 2005 11:15 am
Posts: 970
Location: Montana, United States
Reply with quote
Post 
If I remember right some of those PS to PC adapters are slightly funky and cause issue.

Also, I just have to ask. You are using ZSNES for Windows and not the DOS version right? DOS will not recognize USB devices.


Sat Jan 16, 2010 9:52 pm
Profile
New Member

Joined: Wed Jan 13, 2010 9:21 pm
Posts: 6
Reply with quote
Post 
zsns v1.42 jan 19 2005
win32 version

i assume that's what you were talking about?


Thu Jan 21, 2010 7:56 pm
Profile
Hero of Time
User avatar

Joined: Fri Jul 30, 2004 2:49 am
Posts: 2646
Location: In front of the monitor
Reply with quote
Post 
You could try using the latest ZSNES version. The one you have is very outdated.

_________________
Try out CCleaner and other free software at Piriform
Image


Thu Jan 21, 2010 11:34 pm
Profile WWW
Buzzkill Gil

Joined: Wed Jan 12, 2005 7:14 pm
Posts: 4229
Reply with quote
Post 
If the Windows control panel isn't responding to input, the problem is DEFINITELY not in ZSNES.

_________________
Squall_Leonhart wrote:
Quote:
You have your 2s, 4s, 8s, 16s, 32s, 64s, and 128s(crash course in binary counting!). But no 1s.
DirectInput represents all bits, not just powers of 2 in an axis.


KHDownloads


Fri Jan 22, 2010 8:40 am
Profile
Reply with quote
Post 
odditude wrote:
do you have the controller connected before you launch zsnes?


Haha, wow, thanks, that helped


Tue Feb 09, 2010 6:15 am
New Member

Joined: Sat Jul 11, 2015 1:51 am
Posts: 2
Reply with quote
Post Re: newbie problems with configuring usb gamepad
i know this is old but i'm now having this same problem, my Snes game pad is plugged in, i have one of those where it's a classic controller and you plug it into the USB adapter with 2 game pad slots, i've tried everything... all zsnes wants to recognize is my keyboard, now my PC and laptop both pick up on my controller just fine, i'm using it through a usb hub and running zsnes off my external drive, this isn't causing the issues because i cut and pasted the files onto my laptops deskptop, took out the USB hub with the external drive in it, plugged my game controller directly into the USB port of my laptop, i followed the troubleshooting and it says to plug out any devices that may be using up too much power because some may need more power bla.. bla... usual standard stuff... i rebooted too.

Still i cannot configure the keys... i do the right things and go into Input and Set Keys, nothing happens when i press my controllers buttons, but yet it keeps wanting to pick up on my keyboard, pressing the keyboard keys works fine... i don't know what else to do, but it worked the last time i used it, my system says my controller and the adapter are working properly so it's not that... it doesn't need drivers ether, i've never needed them.


Sat Jul 11, 2015 2:12 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 16 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.