View unanswered posts | View active topics It is currently Thu Sep 19, 2019 2:34 pm



Reply to topic  [ 58 posts ]  Go to page 1, 2, 3  Next
Having trouble with netplay? READ THIS! 
Author Message
Randomness
User avatar

Joined: Wed Jul 28, 2004 4:01 pm
Posts: 1172
Location: UK
Reply with quote
Post Having trouble with netplay? READ THIS!
AntoineWG wrote:
The purpose of this guide is to help users who are not very savvy with networking, but not computer illiterate, to configure their routers properly to host ZSNES netplay sessions or improve their netplay experience with UDP connections and to reduce the number of threads started for port forwarding issues.

Before reading this guide, you will want to read the NETPLAY.TXT and FAQ.TXT that came with ZSNES and your router's manual, as well as any firewall software you may have installed on your computer.

Because this is a guide written by one person, I probably cannot provide you with specific details about your router's configuration because I probably don't own your router. I'll provide at the appropriate point in this thread to a site with more router-specific details than I could ever provide here.

If you are using Windows Internet Connection sharing, this document won't help you. I may update it in the future with details on ICS. For the time being, either get a real router (I recommend Netgear) or use the computer that's connected directly to the modem, or even move the modem to the computer of your choice. ICS may be fine for web browsing and email and port forwarding is possible, but ICS introduces an inordinate amount of lag that other routers do not and it will not give you a very good netplay experience.

You may be asking yourself "Why can't I just put my computer on my router's DMZ? Isn't that easier than setting up port forwarding rules?" Well, yes, it is easier, but the DMZ (de-militarized zone) has one HUGE security hole--the entire IP port range, all 131,072 TCP and UDP ports. Putting your computer basically forwards every incoming connection request to your computer just as if it were connected directly to the modem with out the firewall, while still allowing other computers on the network to use the internet and network like normal. Can you see the problem here? Your computer is left exposed to the internet just the same way as if it didn't have router in front of it and it's an open invitation to all of the unpleasantness that is the internet. It may be easy, but it's like a cheap whore--you might come away clean, but your computer might catch the clap too.

And now on to the actual guide.

Step 1:
Before beginning, you need several pieces of information about your computer and network setup, namely your computer's private IP address (the address you will be forwarding to), your router's private (the address for configuring it) and public (the address your oponent will connect to) IP addresses and some information about ZSNES' specific needs that need not be mentioned at this point.

First off, you need your computer's private IP address. There are 2 ways to get that out of it, depending on what version of Windows you're running.

Step 1.NT
On Windows 98SE/NT/2k/XP/2k3(/Vista?), open the Start menu, then click Run and type cmd in the box and click OK. This will open a command prompt. In there, type ipconfig and hit Enter. This will produce something resembling the following:

Code:
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

D:\Documents and Settings\Tony>ipconfig

Windows IP Configuration


Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 10.1.1.16
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 10.1.1.1

D:\Documents and Settings\Tony>


The IP address should be pretty self explanatory, as it's your computer's private IP address. What you may not know is that 99% of the time, the Default Gateway is your router's private IP address. Write all 3 of these values down or just leave this window open for quick reference because you'll need them later.

Step 1.9x
On Windows 95/98/Me, open the Start menu and click on Run and type winipcfg in the box. It will open up a new window. It will probably list the details for a PPP or dial-up adaptor first. You need to click the down arrow next to the adaptor name to open the dropdown menu listing all of the network adaptors on your system. In addition to your ethernet adaptor, it will probably also list one or more of the following: PPP adaptor, dial-up adaptor, AOL adaptor, 1394 network adaptor. By process of elimination, your network adaptor is most likely the other one that is not in my list. If there are several others (i.e. if you have ethernet WiFi) you may need to try each one. The one with a Default Gateway and IP address is the right one. Write those values down. The IP address is your computer's private IP address and 99% of the time, the Default Gateway is your router's IP address. Write both of these values down. You’ll need them later.

Step 2:
In addition to your computer’s private IP address and default gateway’s (router’s) IP address, you’ll also need your public IP address. Go to http://www.ipchicken.com and write down the IP address it gives you.

Step 3:
Here comes the hard part, working with your router. Because all routers are different, I can’t possibly cover every possible configuration type, but the basic principle is the same on all routers.

To make any changes to the router’s setup, you’ll have to get into it first. The first thing to try is punching in the Default Gateway address in your web browser. Occasionally, to add some degree of security, or at least frustration, they change the port number of this page, usually to 88 or 8080, or use secure HTTP. Examples would be as follows, assuming your default gateway is 192.168.0.1:

http://192.168.0.1
http://192.168.0.1:88
http://192.168.0.1:8080
https://192.168.0.1
https://192.168.0.1:445

Some routers use a default IP address of 172.16.0.1 instead:

http://172.16.0.1
http://172.16.0.1:88
http://172.16.0.1:8080
https://172.16.0.1
https://172.16.0.1:445

If those don’t produce an administration page, consult your router’s manual and check out http://www.portforward.com . They probably have specific instructions for your router.

Here are the settings you need to fill (where applicable) for ZSNES:

Service/Game Name: ZSNES
Public/External Port: 7845 (see notes below)
Private/Internal Port: 7845 (see notes below)
Private/Internal IP Address: (Insert your computer’s private IP address here)
Protocol: Both TCP and UDP (see notes below)

And the setting’s you’ll need in a separate forwarding rule for Zbattle.net:
Service/Game Name: Zbattle
Public/External Port: 4000
Private/Internal Port: 4000
Protocol: UDP only

NOTES:
Some routers allow you to enter a port range for forwarding multiple ports in one entry. In this instance, fill in 7845 for the starting and ending port.

If your router doesn’t allow you to select both TCP and UDP at the same time, you’ll have to create two separate entries with the same settings, one for TCP and one for UDP. You can get by with just TCP, but UDP does not lag as much as TCP.

Step 4:
If you have a software firewall, all of this will be for naught if you don’t configure that properly too. You’ll either need to diable it (you probably don’t need it with a hardware firewall anyways) or set it up to allow incoming connections on ports 7845 and 4000. Because there are so many software firewalls out there (ZoneAlarm, Norton, McAfee, Windows, etc.), I can’t possibly cover them all in this guide. Consult your firewall software’s help files for instructions on how to disable it or allow the computer to accept connections.

Grand Finale
THAT’S IT! If done correctly, you should be ready to host ZSNES netplay games with another person (only one other computer at this time). All you have to do is give them your PUBLIC IP address as reported by http://www.ipchicken.com and plug that into ZSNES.

_________________
ZSNES Documentation Project | bsnes Fan | Official ZSNES Facebook Group


Mon Jun 13, 2005 6:05 am
Profile WWW
Redneck Gamer-Mod
User avatar

Joined: Wed Aug 04, 2004 2:15 am
Posts: 433
Location: Pittsburgh
Reply with quote
Post 
Fix0red...


Sorry, Jo, I deleted your post in the splitting process.

_________________
SHREIK!!!!!!! DDdddnnnnnnaaaa! GESTAHLLLLLLLLLL!!!!!!!!

Steelers now officially own your ass.


Mon Jun 13, 2005 10:35 pm
Profile
New Member

Joined: Fri Aug 12, 2005 11:06 am
Posts: 3
Reply with quote
Post 
I got lost on step 4 :?:


Fri Aug 12, 2005 11:17 am
Profile
Hazed
User avatar

Joined: Tue Jul 12, 2005 5:13 am
Posts: 82
Reply with quote
Post 
note that many routers have default IP addresses of 192.168.1.1, including linksys. Belkin routers are 192.168.2.1

Also, port forwarding is often called "virtual server" or something like that.

_________________
To truly own, you must own at all games.


Fri Aug 12, 2005 4:36 pm
Profile
New Member

Joined: Fri Aug 12, 2005 11:06 am
Posts: 3
Reply with quote
Post 
I don't get this party

Here are the settings you need to fill (where applicable) for ZSNES:

Where do i put this in?


Sat Aug 13, 2005 5:28 am
Profile
New Member

Joined: Sun Dec 19, 2004 6:43 pm
Posts: 5
Reply with quote
Post 
Quick question: Do both people have to have ports forwarded, or just the host?


Thu Aug 18, 2005 10:12 pm
Profile
Locksmith of Hyrule
User avatar

Joined: Sun Aug 08, 2004 7:49 am
Posts: 3634
Location: 255.255.255.255
Reply with quote
Post 
Both computers will have to have the port forwarded.

_________________
Image
<Nach> so why don't the two of you get your own room and leave us alone with this stupidity of yours?
NSRT here.


Fri Aug 19, 2005 4:32 am
Profile YIM WWW
Trooper
User avatar

Joined: Thu Jul 29, 2004 6:59 pm
Posts: 530
Location: 127.0.0.1
Reply with quote
Post 
Only for UDP. TCP only requires that the host forward.

_________________
"It is better to have tried and failed than to have failed to try, but the result's the same." - Mike Dennison


Fri Aug 19, 2005 12:58 pm
Profile WWW
Trooper
User avatar

Joined: Thu Jul 29, 2004 6:59 pm
Posts: 530
Location: 127.0.0.1
Reply with quote
Post 
I retitled the thread to hopefully make it more obvious.

_________________
"It is better to have tried and failed than to have failed to try, but the result's the same." - Mike Dennison


Thu Jan 19, 2006 6:52 pm
Profile WWW
Rookie

Joined: Thu Aug 18, 2005 3:07 am
Posts: 11
Reply with quote
Post 
This is great!!! thanks guys, i got it to work this time.

_________________
Zsnes is by FAR the best emulator ever created!!!
Best RPG game ever = Chrono trigger
MMORPG's rule!


Sun Jan 22, 2006 5:40 am
Profile
Rookie

Joined: Fri Apr 21, 2006 6:13 am
Posts: 11
Reply with quote
Post 
Quote:
If those don’t produce an administration page, consult your router’s manual and check out http://www.portforward.com . They probably have specific instructions for your router.

Here are the settings you need to fill (where applicable) for ZSNES:

Service/Game Name: ZSNES
Public/External Port: 7845 (see notes below)
Private/Internal Port: 7845 (see notes below)
Private/Internal IP Address: (Insert your computer’s private IP address here)
Protocol: Both TCP and UDP (see notes below)

And the setting’s you’ll need in a separate forwarding rule for Zbattle.net:
Service/Game Name: Zbattle
Public/External Port: 4000
Private/Internal Port: 4000
Protocol: UDP only


Okay, I'm stuck on this part. I'm at the administration page, but I don't know where to fill out this information at.


Fri Apr 21, 2006 7:39 am
Profile
Rookie

Joined: Fri Apr 21, 2006 6:13 am
Posts: 11
Reply with quote
Post 
Okay, forget my above question. I figured that part out, but I'm still stuck. I don't know where to put this information since my administration page has something else.

Quote:
Service/Game Name: ZSNES
Public/External Port: 7845 (see notes below)
Private/Internal Port: 7845 (see notes below)
Private/Internal IP Address: (Insert your computer’s private IP address here)
Protocol: Both TCP and UDP (see notes below)


You see, this is what mine looks like and I don't know what to put in.

Image


Sat Apr 22, 2006 7:02 am
Profile
ZSNES Developer
ZSNES Developer

Joined: Tue Dec 28, 2004 6:47 am
Posts: 6747
Reply with quote
Post 
Did you read Clements notes at all?

Global Port Range = Public/External Port

Clements wrote:
NOTES:
Some routers allow you to enter a port range for forwarding multiple ports in one entry. In this instance, fill in 7845 for the starting and ending port.


Base Host Port = Public/Internal Port

Protocol...

Quote:
If your router doesn’t allow you to select both TCP and UDP at the same time, you’ll have to create two separate entries with the same settings, one for TCP and one for UDP. You can get by with just TCP, but UDP does not lag as much as TCP.

_________________
Continuing FF4 Research...


Sat Apr 22, 2006 8:02 am
Profile
Trooper
User avatar

Joined: Thu Jul 29, 2004 6:59 pm
Posts: 530
Location: 127.0.0.1
Reply with quote
Post 
Global Port range = 7845 to 7845

Base Host Port = 7845

Create 2 forwarding entries - one for TCP and one for UDP.

_________________
"It is better to have tried and failed than to have failed to try, but the result's the same." - Mike Dennison


Sat Apr 22, 2006 4:39 pm
Profile WWW
Rookie

Joined: Fri Apr 21, 2006 6:13 am
Posts: 11
Reply with quote
Post 
Okay, but there is no where to put my Private/Internal IP Address as the instructions said.


Sat Apr 22, 2006 5:10 pm
Profile
Rookie

Joined: Fri Apr 21, 2006 6:13 am
Posts: 11
Reply with quote
Post 
Okay, never mind. I fixed it.


Sat Apr 22, 2006 8:44 pm
Profile
Reply with quote
Post 
Hello guys, Im having some problems to play online since I got my new modem with router.
Im stuck in this part, see the screens, I dont know why this is happening its pretty strange actually:
http://img173.imageshack.us/my.php?image=step14mr.jpg <- step 1
http://img174.imageshack.us/my.php?image=step29tw.jpg <- step 2
http://img185.imageshack.us/img185/9346 ... ply3gy.jpg <- after apply

So, any ideas?


Mon May 01, 2006 1:40 am
16-bit Corpse | Nyoron~
User avatar

Joined: Sun Aug 01, 2004 7:14 pm
Posts: 3534
Location: Nokia Land
Reply with quote
Post 
Your router settings thinks that what you entered is not really a port range at all, since the values are the same (furthermore, the router thinks that the Ending Port number is smaller). Try setting the Ending Port one larger than the Starting port.

_________________
whicker: franpa is grammatically correct, and he still gets ripped on?
sweener2001: Grammatically correct this one time? sure. every other time? no. does that give him a right? not really.
Image


Mon May 01, 2006 11:09 am
Profile
Reply with quote
Post 
Agozer wrote:
Your router settings thinks that what you entered is not really a port range at all, since the values are the same (furthermore, the router thinks that the Ending Port number is smaller). Try setting the Ending Port one larger than the Starting port.


yay that wordked! Now I can play online again with udp (yuhuuu no lags :P ) ;D, thanks a lot buddy!


Mon May 01, 2006 3:12 pm
Reply with quote
Post 
Hmm, I was following the guide on portforward.com and it told me to do this for my modem:

Image

I just want to know if this is ALL i need to do? I thought I had to put my ip somewhere?


Mon Jun 26, 2006 3:38 am
Reply with quote
Post 
ok im new here and i got probs with my new router

I´m german so i got an german t-online Speedport 500v router dont know if anybody knows this so.. i can enter udp and tcp but if i make it so

tcp:4000
udp:7845

then it says port numbers incorecct or something plz can some1 of you guys help me im beggin you


Sun Nov 26, 2006 1:06 am
ZSNES Developer
ZSNES Developer

Joined: Tue Dec 28, 2004 6:47 am
Posts: 6747
Reply with quote
Post 
Volnox wrote:
ok im new here and i got probs with my new router

I´m german so i got an german t-online Speedport 500v router dont know if anybody knows this so.. i can enter udp and tcp but if i make it so

tcp:4000
udp:7845

then it says port numbers incorecct or something plz can some1 of you guys help me im beggin you


You probably want to use the same port #s when you are entering it in.

_________________
Continuing FF4 Research...


Sun Nov 26, 2006 1:10 am
Profile
Reply with quote
Post 
thx for the quick answer but i dont know what u mean with that im really sry


Sun Nov 26, 2006 1:18 am
ZSNES Developer
ZSNES Developer

Joined: Tue Dec 28, 2004 6:47 am
Posts: 6747
Reply with quote
Post 
Volnox wrote:
thx for the quick answer but i dont know what u mean with that im really sry


Your router/firewall software may be expecting the same port number entered in both UDP+TCP.

Either that, or it expects one or the other to be filled (but not both).

_________________
Continuing FF4 Research...


Sun Nov 26, 2006 1:22 am
Profile
Reply with quote
Post 
ok, hello everyone =) I'm new here and have a question concering this:

at step 3, it asks me to log in - but I don't know what to type. sorry I know I'm stupid T_T is the name of my computer requested here? and where can I find the password?

thanks so much in advance for helping ^^


Sat Jan 27, 2007 4:30 pm
Display posts from previous:  Sort by  
Reply to topic   [ 58 posts ]  Go to page 1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.