View unanswered posts | View active topics It is currently Sat Apr 04, 2020 7:30 pm



Reply to topic  [ 7 posts ] 
Working ZSNES netplay builds for Ubuntu 
Author Message
New Member

Joined: Sat Jun 04, 2011 7:27 pm
Posts: 1
Reply with quote
Post Working ZSNES netplay builds for Ubuntu
Hey everyone,

If you are searching for a working build of ZSNES for Ubuntu that will work with netplay, you can find old debs in the Ubuntu archives:

http://old-releases.ubuntu.com/ubuntu/p ... e/z/zsnes/

I am running Ubuntu 11.04 x86-64, and I have so far had no problems with netplay using the zsnes_1.420-2ubuntu1_i386.deb package. I haven't tested save state loading, yet, so I can't say if that works right now. At any rate, if you've been looking for binaries and don't want to mess with compiling the old releases, you may want to give these packages a try.

Edit: To install the i386 package on x86-64 Ubuntu, make sure you have the ia32 libs installed (should be standard on x86-64 releases now) and do the following:
Code:
sudo dpkg --force-architecture -i zsnes_1.420-2ubuntu1_i386.deb

Since it's an old package, you may get warnings about the dependency version mismatches, but as far as I know, this hasn't affected zsnes's functionality or performance.


Sat Jun 04, 2011 7:41 pm
Profile
New Member

Joined: Sun Jun 12, 2011 11:59 pm
Posts: 1
Reply with quote
Post Re: Working ZSNES netplay builds for Ubuntu
This is what I got, any suggestions?

Quote:
l1xx3r@Mini:~/Downloads$ sudo dpkg --force-architecture -i zsnes_1.420-2ubuntu1_i386.deb
dpkg: warning: overriding problem because --force enabled:
package architecture (i386) does not match system (amd64)
(Reading database ... 143348 files and directories currently installed.)
Preparing to replace zsnes:i386 1.420-2ubuntu1 (using zsnes_1.420-2ubuntu1_i386.deb) ...
Unpacking replacement zsnes:i386 ...
dpkg: dependency problems prevent configuration of zsnes:i386:
zsnes:i386 depends on libc6 (>= 2.4-1).
zsnes:i386 depends on libgcc1 (>= 1:4.1.1-11ubuntu1).
zsnes:i386 depends on libpng12-0 (>= 1.2.8rel).
zsnes:i386 depends on libsdl1.2debian (>= 1.2.10-1).
zsnes:i386 depends on libstdc++6 (>= 4.1.1-11ubuntu1).
zsnes:i386 depends on zlib1g (>= 1:1.2.1).
dpkg: error processing zsnes:i386 (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
zsnes:i386


Mon Jun 13, 2011 12:02 am
Profile
"Your thread will be crushed."
User avatar

Joined: Wed Jul 28, 2004 1:49 am
Posts: 1234
Location: Not in Winnipeg
Reply with quote
Post Re: Working ZSNES netplay builds for Ubuntu
Like the first post says, you are missing packages that zsnes depends on.

In all likelihood, it will mean you will have to install old versions of said packages.

_________________
<pagefault> i'd break up with my wife if she said FF8 was awesome


Mon Jun 13, 2011 12:29 pm
Profile WWW
Zealot
User avatar

Joined: Sat Jul 02, 2005 2:01 am
Posts: 1076
Reply with quote
Post Re: Working ZSNES netplay builds for Ubuntu
Probably not easy to install such an old libc, without breaking _everything_.

_________________
Maybe these people were born without that part of their brain that lets you try different things to see if they work better. --Retsupurae


Mon Jun 13, 2011 5:52 pm
Profile WWW
Official tech support dood

Joined: Wed Jan 25, 2006 7:57 am
Posts: 2098
Reply with quote
Post Re: Working ZSNES netplay builds for Ubuntu
paulguy wrote:
Probably not easy to install such an old libc, without breaking _everything_.

according to the first post, it's working fine.

_________________
Why yes, my shift key *IS* broken.


Mon Jun 13, 2011 11:14 pm
Profile
Zealot
User avatar

Joined: Sat Jul 02, 2005 2:01 am
Posts: 1076
Reply with quote
Post Re: Working ZSNES netplay builds for Ubuntu
Oh yeah it says >=. Not sure why he wouldn't have those particular packages. Probably something wrong with his set up outside of not being able to install that package, or just Ubuntu being like Windows and doing stupid crap and providing completely unuseful error messages.

_________________
Maybe these people were born without that part of their brain that lets you try different things to see if they work better. --Retsupurae


Mon Jun 13, 2011 11:20 pm
Profile WWW
Official tech support dood

Joined: Wed Jan 25, 2006 7:57 am
Posts: 2098
Reply with quote
Post Re: Working ZSNES netplay builds for Ubuntu
magneticanomaly wrote:
make sure you have the ia32 libs installed

_________________
Why yes, my shift key *IS* broken.


Tue Jun 14, 2011 5:38 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.