bsnes v0.041 released

Archived bsnes development news, feature requests and bug reports. Forum is now located at http://board.byuu.org/
Locked
FitzRoy
Veteran
Posts: 861
Joined: Wed Aug 04, 2004 5:43 pm
Location: Sloop

Post by FitzRoy »

byuu wrote:Could you elaborate on that?


My 3rd post of Pg.2, I made a suggestion that you agreed to. I think you may have forgotten about it.

Yeah, but then you can already tell what you're on from the left-hand listbox.


Not if it's been minimized, anyway.
Verdauga Greeneyes
Regular
Posts: 347
Joined: Tue Mar 07, 2006 10:32 am
Location: The Netherlands

Post by Verdauga Greeneyes »

Got something odd just now: I changed my controller from the default drivers to drivers from the manufacturer, and when I used 'Assign All' in bsnes the 'this controller must be calibrated' box popped up only -after- I'd already assigned 'up'. I'd already tested it successfully with the stock drivers before then, and button assignment still worked regardless.
byuu

Post by byuu »

Verdauga Greeneyes wrote:Got something odd just now: I changed my controller from the default drivers to drivers from the manufacturer, and when I used 'Assign All' in bsnes the 'this controller must be calibrated' box popped up only -after- I'd already assigned 'up'. I'd already tested it successfully with the stock drivers before then, and button assignment still worked regardless.


It's because your driver sent an analog motion signal after you pressed up. Most likely it was reporting all neutral values until any button was pressed, and up on your controller wasn't actually an analog input but a POV hat.
Jipcy
Veteran
Posts: 768
Joined: Thu Feb 03, 2005 8:18 pm
Contact:

Post by Jipcy »

byuu wrote:Okay then, if everyone possible could test this quickly, I can post a new release tonight. Especially the input mapping, and especially there for gamepads / controllers.

When I open the WIP, this is all I see:
http://www.endoftransmission.net/pics/bsnes_error.png
I freezes the entire screen. I can move the mouse, but I can't click on anything in or outside the black box. No keyboard response or mouse click response. I can still open up the Task Manager and kill the process though.
I'm on Vista SP1.
byuu

Post by byuu »

Kiddo, you were right about there being a BS-X bug. Actually there were two, heh.

On Windows, it wasn't copying the BIOS name over correctly; and after that, it was throwing errors when you went to boot the cart from the town menu. That took me nearly three hours to track down. Apparently, I changed virtual unsigned Memory::size() to virtual unsigned Memory::size() const, but didn't update BSXFlash::size() to const as well, so it was ignoring it and using the base type, returning 0 for the cart size, which broke mapping.

Jipcy, sorry. I have no idea why that's happening. bsnes isn't a raster-only UI, so there's absolutely no reason you shouldn't at least see the title bars. I hope it's automagically fixed in the new official release, or you may be out of luck :/

I'd say try deleting the bsnes.cfg file (start->run->%appdata% <enter>, delete .bsnes folder). Failing that, set system.video/audio/input to "None" to rule out driver issues. Failing that, re-install DirectX 9.0c run-time. Failing that, ... I hope you know how to program.
Locked