List the dependencies for Zsnes

The official forum for ZSNES documentation. Discuss future changes, mistakes, etc...
You can also join us on IRC at irc.freenode.net in #zsnes-docs.

Moderators: ZSNES Mods, ZSNES Doc Team

Post Reply
qwerty800

List the dependencies for Zsnes

Post by qwerty800 »

It's so much easier to compile a program when you know which dependencies to install!

The problem is that they aren't listed anywhere!
Sure, there is apt-get build-dep for debian & ubuntu, but for some other distros, thee packages aren't even aviables!

The only solution remaining is to look into the "configure" script, but it almost contain 7000 (OVER 9000!!!!!) lines!

It would be appreciable if somebody could just post the dependencies here, so that nobody would need to seach anymore.
Deathlike2
ZSNES Developer
ZSNES Developer
Posts: 6747
Joined: Tue Dec 28, 2004 6:47 am

Post by Deathlike2 »

I'm sure you can figure it out if you read the docs. There tends to be equivalent packages for accomplishing the same thing.
Continuing FF4 Research...
adventure_of_link
Locksmith of Hyrule
Posts: 3634
Joined: Sun Aug 08, 2004 7:49 am
Location: 255.255.255.255
Contact:

Post by adventure_of_link »

don't we have the needed programs/libraries to compile ZSNES somewhere in the FAQs on the board :?
Image
<Nach> so why don't the two of you get your own room and leave us alone with this stupidity of yours?
NSRT here.
Nach
ZSNES Developer
ZSNES Developer
Posts: 3903
Joined: Tue Jul 27, 2004 10:54 pm
Location: Solar powered park bench
Contact:

Post by Nach »

Actual dependencies change from distro to distro.
May 9 2007 - NSRT 3.4, now with lots of hashing and even more accurate information! Go download it.
_____________
Insane Coding
Post Reply