Zsnes 1.42 Crashes upon loading rom via netplay

Want to play with a friend over the net? Find out all the info you need on how to configure your PC, network and of course ZSNES. Also the correct place to find people to play with and what software they use.

Moderator: ZSNES Mods

Post Reply
HighanDry
New Member
Posts: 9
Joined: Sat Jun 26, 2010 3:55 am

Zsnes 1.42 Crashes upon loading rom via netplay

Post by HighanDry »

Before I explain the problem, I play with one of my friends on donkey kong and netplay works PERFECTLY, save/load stats chat every works great.

However with this guy i'm trying to netplay with, we connect fine, we're in the chatroom (connection successful)

When I go to load up a rom (Any rom)

That we both have, zsnes simply freezes and shows the game drop down i.e load etc...

we're using hamachi, zsnes 1.42, basically the same stuff i'm using with my other friend and it works perfectly.

Only problem I had with my other friend which is similiar, if he maximized before we loaded the game our zsnes's would crash, however if he kept it windowed and Maximized it after the game loaded it was fine.

And yes I asked this new guy if he was doing the same (Maximizing before loading) and he said no.

Edit:

Just to clarify further, yes this guy can play games on zsnes fine, they load, they have sound he can play perfectly.

It is only when I try to load them when we are connected via netplay that our zsnes's crash. hope this helps.

So i'm really at a lost here of why I cannot net play with this guy when we're doing the exact same thing as when I play with my other friend and everything works perfectly.
Deathlike2
ZSNES Developer
ZSNES Developer
Posts: 6747
Joined: Tue Dec 28, 2004 6:47 am

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by Deathlike2 »

My only guess is that there is a path issue with the other person's system. Make sure there are no spaces in the path to the files.
Continuing FF4 Research...
HighanDry
New Member
Posts: 9
Joined: Sat Jun 26, 2010 3:55 am

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by HighanDry »

Deathlike2 wrote:My only guess is that there is a path issue with the other person's system. Make sure there are no spaces in the path to the files.


?

He can load the games fine on his own though. Its just when we try to netplay together it freezes
Deathlike2
ZSNES Developer
ZSNES Developer
Posts: 6747
Joined: Tue Dec 28, 2004 6:47 am

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by Deathlike2 »

Well, netplay was never "working" perfectly.. which is why netplay has to be totally redone in the first place (these issues should never crop up).

The only thing I can come up with is the game you're trying to play... some games that have save RAM (those that generate SRM file like most RPG games) can be problematic.
Continuing FF4 Research...
HighanDry
New Member
Posts: 9
Joined: Sat Jun 26, 2010 3:55 am

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by HighanDry »

Deathlike2 wrote:Well, netplay was never "working" perfectly.. which is why netplay has to be totally redone in the first place (these issues should never crop up).

The only thing I can come up with is the game you're trying to play... some games that have save RAM (those that generate SRM file like most RPG games) can be problematic.


we've tried many roms mate. same exact result for each.

Besides, why would the exact same rom work with my other friend but not this guy?

Net play does work perfectly with my other friend.

We have played and beaten SD3 secret of mana donkey kong country all without any hitches, desyncs or crashes.
Deathlike2
ZSNES Developer
ZSNES Developer
Posts: 6747
Joined: Tue Dec 28, 2004 6:47 am

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by Deathlike2 »

Well, I have no idea as I said.

Just make sure the other guy has no spaces in his path (no folder can have a space in it). The primary reason for this is that spaces affect the poor parsing that the config file used to perform. Additionally, these issues can manifest themselves on a network game than locally... it's just how finicky it is.
Continuing FF4 Research...
HighanDry
New Member
Posts: 9
Joined: Sat Jun 26, 2010 3:55 am

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by HighanDry »

he didn't modify his path so, there would'nt be spaces, it is whatever it is as the default is.

but ty for your help

does anyone else have any idea what the issue could be?
franpa
Gecko snack
Posts: 2372
Joined: Sun Aug 21, 2005 11:06 am
Location: Australia, QLD
Contact:

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by franpa »

There is no default path ZSNES is installed to as there is no installer for ZSNES.
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64
HighanDry
New Member
Posts: 9
Joined: Sat Jun 26, 2010 3:55 am

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by HighanDry »

well i don't get what hes suggesting I do.

if you do everything the default way, extracting zsnes into a premade folder on your desktop, there isnt going to be spaces.

I also checked the paths in the config, no spaces there either.

So basically theres no spaces anywhere, if you do everything the default way, which is what he did, cause he installed zsnes exactly as I did.
franpa
Gecko snack
Posts: 2372
Joined: Sun Aug 21, 2005 11:06 am
Location: Australia, QLD
Contact:

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by franpa »

Your friend whom your trying to play with (and is crashing for them) may have spaces in there path, that is what he was getting at. His login name may contain spaces.
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64
HighanDry
New Member
Posts: 9
Joined: Sat Jun 26, 2010 3:55 am

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by HighanDry »

franpa wrote:Your friend whom your trying to play with (and is crashing for them) may have spaces in there path, that is what he was getting at. His login name may contain spaces.


His nickname? For netplay?
franpa
Gecko snack
Posts: 2372
Joined: Sun Aug 21, 2005 11:06 am
Location: Australia, QLD
Contact:

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by franpa »

No I mean his Windows Login. As his Desktop is positioned within his User folder. For instance if he uses Windows 7 and his user name was Adam Scott then the path to his desktop would be...

C:\Users\Adam Scott\Desktop

Creating a space in the path to anything on the desktop.
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64
paulguy
Zealot
Posts: 1076
Joined: Sat Jul 02, 2005 2:01 am
Contact:

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by paulguy »

Don't forget that if he uses Windows XP, the desktop will be under C:\Documents and Settings\...\Desktop, which already has spaces. So he may have to put it under C:\zsnes\roms or something just to prevent the possibility of an issue.
Maybe these people were born without that part of their brain that lets you try different things to see if they work better. --Retsupurae
HighanDry
New Member
Posts: 9
Joined: Sat Jun 26, 2010 3:55 am

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by HighanDry »

paulguy wrote:Don't forget that if he uses Windows XP, the desktop will be under C:\Documents and Settings\...\Desktop, which already has spaces. So he may have to put it under C:\zsnes\roms or something just to prevent the possibility of an issue.


I have xp and mine is on the desktop... -_-

I know you are allt rying to help and all but everythings workin fine under the circumstances with me and I have everything wrong that you guys are listing and i play fine with 2 people now. no desyncs or load issues at all
Abzug86
New Member
Posts: 2
Joined: Sun Jan 15, 2012 8:26 pm

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by Abzug86 »

Hey guys,

just found that thread, though its quite old.

I've got some similar issue. More like 2 issues, one of them not that big of a deal though. Lemme explain:

I started playing online around 5 or 6 years ago, using ZSNEs 1.42 all the way on a Windows XP computer, arranging matches via zbattle.net. Had to configure my router (port forwarding) and my firefall back then to get it work. After I've done that, everything worked extremely well, no connection issues whatsoever.

Had some time out in 2010/2011. Got a new computer, Windows 7 64-Bit. Restarted playing online (massively), this time using Hamachi to make matches since it makes connecting much easier. From Day 1 on I could only maximize ZSNES when having Firefox in the backround. Not kidding. If Firefox isn't on, ZSNES crashes when maximizing. More than that, Firefox needs to run once, not twice (would make ZSNES crash as well). There's another guy in our community who has the exact same issue (running on Win7 64-Bit as well). But since its easy to deal with that, it's not really an issue anymore. Just some extremely weird bug I guess....

Bigger problem is: ZSNES crashes randomly when loading a rom after having connected. Means, I can start server/connect to server with no problems at all, talk to the other player fine. But when loading a rom (no matter if its me or him that loads it), ZSNES sometimes just loads it fine, sometimes crashes (sometimes infinite times in a row, but then a few hours later it does it perfectly fine). Since we are some pretty big communitiy and do tournaments, I withnessed this bug with (guessing) ~ 50 different guys, having this issue with all of them - sometimes. So its definately on my side.

Tried everything, starting ZSNES/hamachi with admin rights, compatibility mode, forwarding ports (though it shouldn't be a need for that when using Hamachi), creating exception rules for Firewall, re"installing" ZSNES.... everything you can imagine I guess. Nothing worked. Any new knowledge about this?

Thx for helping!

Greets Abzug86
Abzug86
New Member
Posts: 2
Joined: Sun Jan 15, 2012 8:26 pm

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by Abzug86 »

Oh wow, thats what I call a usefull and frequented board.
odditude
Official tech support dood
Posts: 2106
Joined: Wed Jan 25, 2006 7:57 am

Re: Zsnes 1.42 Crashes upon loading rom via netplay

Post by odditude »

...or maybe nobody has any useful info for you. There's likely a background app or service that's causing the issue; trial-and-error is you best hope of isolating what it is.
Why yes, my shift key *IS* broken.
Post Reply