Odd controller issue with both of my computers.

Gamepad acting up? Keyboard not responding properly? Can't get that other user to work? Read and post about it here.

Moderator: ZSNES Mods

Post Reply
Chewy1015
New Member
Posts: 1
Joined: Sun Aug 23, 2015 11:55 pm

Odd controller issue with both of my computers.

Post by Chewy1015 »

Hello there everyone. So I just downloaded ZSNES and then I plugged my Xbox One controller in. Before I opened ZSNES, I calibrated my Xbox One controller and everything is fine and dandy and it reads. I open up ZSNES, go to Config, select Input, make sure it's on #1, then I select Keyboard/Mouse. After that, I decide I want to set the controls to my Xbox One controller. So I hit Set Keys and first, it asks me to hit a button I want for Up. So I hit the Up button on my Xbox One controller, and it reads and all, and then it asks to hit a button that I want for Down. It is at this point that everything freezes up. So I try another way where I select each key manually. I do Up first and it works, but once I even select all the other keys, they just set to J08 (whatever that is). This is both on my Windows 10 laptop AND my Windows 7 desktop. Has anyone else had this issue and if so, do you know the solution?
12dddduddits
New Member
Posts: 1
Joined: Mon Oct 12, 2015 4:01 am

Re: Odd controller issue with both of my computers.

Post by 12dddduddits »

The EXACT thing happens to mine. the controller works 100% in any other application, even other emulators, just not zsnes. I have restarted, reinstalled drivers, tried all older versions and the newest version of zsnes, but nothing works at all. if i manually set the keys, it automatically presses joy5 ?
does anyone at all know what to do??
thanks !
Truth Unknown
Regular
Posts: 271
Joined: Tue Jun 14, 2005 8:35 pm

Re: Odd controller issue with both of my computers.

Post by Truth Unknown »

Microsoft changed the analog triggers to use Z and RZ instead of sharing just Z. Unfortunately, each trigger is mapped for the entire axis so the trigger at rest will be at full negative axis. You will need to somehow press both triggers to be at center and then select each key. I folded two sticky notes, wedged them next to the triggers and opened controller calibration and centered the triggers and when back to set my buttons. Setting triggers will be a bit tedious, and must be done on the individual key then reset the triggers before the next.
ghsty8
New Member
Posts: 1
Joined: Mon Jan 18, 2016 3:46 am

Re: Odd controller issue with both of my computers.

Post by ghsty8 »

12dddduddits wrote:The EXACT thing happens to mine. the controller works 100% in any other application, even other emulators, just not zsnes. I have restarted, reinstalled drivers, tried all older versions and the newest version of zsnes, but nothing works at all. if i manually set the keys, it automatically presses joy5 ?
does anyone at all know what to do??
thanks !




Hi all,
I had some trouble setting up my xbox one controller (only getting JOY5) so I spent some time working with the config file and came up with this list.

Player 1 Input
; Input Device: 0 = Unplugged, 1 = KEYBOARD/GAMEPAD
pl1contrl=1
; Keys for Select, Start, Up, Down, Left, Right, X, A, L, Y, B, R
pl1selk=278
pl1startk=279
pl1upk=259
pl1downk=258
pl1leftk=257
pl1rightk=256
pl1Xk=275
pl1Ak=273
pl1Lk=276
pl1Yk=274
pl1Bk=272
pl1Rk=277

place all these numbers into their places in your zinput.cfg
this will put all buttons (Nintendo controller ones anyhow) into their correct places and should not be an issue anymore.

Hope this helps somebody!
Kiromitsu
New Member
Posts: 2
Joined: Sun Mar 13, 2016 4:58 am

Re: Odd controller issue with both of my computers.

Post by Kiromitsu »

If I have an xbone controller plugged into my pc at ALL when I start Zsnes the program is pretty much frozen. Cursor wont move and I am incapable of selections even with keyboard input. As soon as the controller is unplugged everything works fine again lol. Looks like I'm stuck with a keyboard for a while...
Post Reply