Can someone help me with this

Announce new emulators, discuss which games run best under each emulator, and much much more.

Moderator: General Mods

Post Reply
Binkerdoodle
New Member
Posts: 3
Joined: Sat Sep 26, 2015 2:13 am

Can someone help me with this

Post by Binkerdoodle »

I use SNES9K and each time when i try to play Kirby Super star with a friend it says "If you are using a superscope, mouse, or multiplayer adapter, switch to controller." how do i make it stop doing that im using keyboard
Cammygirl192
can't make up their mind
Posts: 79
Joined: Sun Sep 13, 2015 7:51 pm
Location: England
Contact:

Re: Can someone help me with this

Post by Cammygirl192 »

I don't know anything about that emulator, but probably you haven't set it to use a controller or you've select other controller type included.

Or, use ZSNES with netplay (1.4x)
Dell XPS M1530 PP28L | Intel Core 2 Duo T7250 (2.00GhZ) | NVIDIA GeForce 8600M | 4GB RAM | Windows Vista Home Premium 64-bit
Gaminable - sadly doesn't have a snazzy UI like ZSNES's
Gil_Hamilton
Buzzkill Gil
Posts: 4267
Joined: Wed Jan 12, 2005 7:14 pm

Re: Can someone help me with this

Post by Gil_Hamilton »

I'm almost certain he means SNES9X. (I was also sure I made a sarcastic mockery of the misspelling previously, but apparently not).
Which is a far better choice than ZSNES at present. In general, but also ESPECIALLY for SA1 games like Kirby.
ZSNES' SA1 emulation is best described as "completely broken".

The error originates from the game, not from the emulator.
For original hardware reasons, the game will not boot if a multitap is detected, regardless of how many controllers are plugged in. For simplicity reasons, most emulators emulate a multitap connected by default.

I'm not sure what to do to kill multitap emulation in SNES9x.



And there is no ZSNES 1.4. Unofficial hacks are unofficial.
Squall_Leonhart wrote:
You have your 2s, 4s, 8s, 16s, 32s, 64s, and 128s(crash course in binary counting!). But no 1s.
DirectInput represents all bits, not just powers of 2 in an axis.


KHDownloads
odditude
Official tech support dood
Posts: 2107
Joined: Wed Jan 25, 2006 7:57 am

Re: Can someone help me with this

Post by odditude »

snes9k is a mod of snes9x that uses kalliera for netplay. don't know what version it's forked from, though.
Why yes, my shift key *IS* broken.
Cammygirl192
can't make up their mind
Posts: 79
Joined: Sun Sep 13, 2015 7:51 pm
Location: England
Contact:

Re: Can someone help me with this

Post by Cammygirl192 »

The last version appears to be dated 3/4/2005 (D/M/Y system), and the last version of snes9x appears to be from 2011.
Dell XPS M1530 PP28L | Intel Core 2 Duo T7250 (2.00GhZ) | NVIDIA GeForce 8600M | 4GB RAM | Windows Vista Home Premium 64-bit
Gaminable - sadly doesn't have a snazzy UI like ZSNES's
odditude
Official tech support dood
Posts: 2107
Joined: Wed Jan 25, 2006 7:57 am

Re: Can someone help me with this

Post by odditude »

Termingamer2-JD wrote:The last version appears to be dated 3/4/2005 (D/M/Y system), and the last version of snes9x appears to be from 2011.

the last build of snes9x is from may. OV2's most recent builds can be found here, and are regularly linked to from the snes9x board.
Why yes, my shift key *IS* broken.
Cammygirl192
can't make up their mind
Posts: 79
Joined: Sun Sep 13, 2015 7:51 pm
Location: England
Contact:

Re: Can someone help me with this

Post by Cammygirl192 »

I meant to say the last release (1.53), not the last build, sorry.
Dell XPS M1530 PP28L | Intel Core 2 Duo T7250 (2.00GhZ) | NVIDIA GeForce 8600M | 4GB RAM | Windows Vista Home Premium 64-bit
Gaminable - sadly doesn't have a snazzy UI like ZSNES's
grinvader
ZSNES Shake Shake Prinny
Posts: 5626
Joined: Wed Jul 28, 2004 4:15 pm
Location: PAL50, dood !

Re: Can someone help me with this

Post by grinvader »

Just follow what it says and disable any kind of special input in port #2.
皆黙って俺について来い!!

Code: Select all

<jmr> bsnes has the most accurate wiki page but it takes forever to load (or something)

Pantheon: Gideon Zhi | CaitSith2 | Nach | kode54
Post Reply