Chrono Trigger Save Mayhem

Found a bug? Please report it, but remember to follow the bug reporting guidelines.
Missing a sane feature? Let us know!
But please do NOT request ports to other systems.

Moderator: ZSNES Mods

Post Reply
New Member
Posts: 1
Joined: Sat Aug 13, 2016 6:20 am

Chrono Trigger Save Mayhem

Post by Mechobra »

I cannot describe in words how absolutely livid I am at the time of writing this. The fact that this is happened to me on 3 different occasions is absurd and quite frankly ridiculous at this point.

This summer I decided to begin playing Chrono Trigger anew, since the last time I attempted to play it I just randomly halted an hour in and never played it again. Needless to say, over the past week or so, I fell in love with the game. But as soon as I reached Magus' Castle, problems arose with the saving. To begin with, I save stated before the boss battle just in case the game crashes or some sort of technical errors occur. I figured this was going to be a major boss battle so I didn't want anything to go wrong. Little did I know this would spark a chain of events that I legitimately can't answer for. After I beat Magus, I was sent to the prehistoric age. I saved as normal, and then turned the game off. But when I started the game the next morning, I was back at Magus' castle. Okay, maybe I didn't save even though I thought I did. No biggie.

So I beat Magus again and continued onward. Because I didn't want another save issue, I save stated at the prehistoric era. I played the game as usual and saved in-game at every opportunity. Soon enough I made to the Azala boss battle, and save stated once again, because I had to go somewhere for a little while. I exited the emulator and ran my errands. When I started up the game again, guess where I was? Magus' Castle. I couldn't fathom how this had happened seeing as how I literally saved countless times just for safety for this not happening again. Not only that, but I literally save stated! I searched my files completely and the state was no where to be found. After a day, I decided to replay that section of the game and quit pouting about losing some progress. And so I started up the save state I made in the prehistoric age right when I entered it upon beating Magus.

I made to the Azala fight, this time beating him and making my way through the game. After you beat him, you move on to the Kingdom of Zeal. I made it to the kingdom and decided that I should call it a day and go to bed. I tried to save state this time (and regularly saved in game) but then I came to a horrific text. "Unable to save state 0." I stared in anger and disbelief. The one time I need to save, and I can't? Are you kidding me? I tried every possible state possible, but it would not save under any circumstances. I scrolled through all game files and former states, but nothing could make me save this game. I saved in-game a total of 23 times just to be safe. There was no way I could make a save state, so saving in game was my only hope of picking up right where I left off.

I exited the emulator.
I loaded the game.

I'm at Magus' Castle.

I'm done with the game at this point. I absolutely refuse to redo the entire prehistoric era for a THIRD time in addition to making it to Zeal again. I can only find consolation in someone please explaining to me why I couldn't save state, and why I ended up in Magus' Castle every time I loaded up the game even after literally playing in the Kingdom of Zeal (and saving) mere minutes earlier. I doubt I could recover my Zeal save points because they're pretty much gone at this point. I only hope that someone can explain why this occurred to me. Looks like I'm done playing Chrono Trigger for a second time.

TL;DR: My save point I made at Magus' Castle is where the game loads at every single time I resume playing the game, possibly due to the fact that I made a save state at the area.
"Your thread will be crushed."
Posts: 1236
Joined: Wed Jul 28, 2004 1:49 am
Location: Not in Winnipeg

Re: Chrono Trigger Save Mayhem

Post by badinsults »

Sounds like you have it set up to automatically load the save state? Maybe the save state file is set to be read-only, which would explain why you can't overwrite it (and maybe why your SRAM saves are also not working). Check your files.
<pagefault> i'd break up with my wife if she said FF8 was awesome
Gecko snack
Posts: 2372
Joined: Sun Aug 21, 2005 11:06 am
Location: Australia, QLD

Re: Chrono Trigger Save Mayhem

Post by franpa »

Save States include the SRAM (Where the in-game save data is stored) and when you load a state it will overwrite the SRAM with the copy associated with the Save State. So if you are loading an old Save State it will replace your current in-game save data with old data. This is done because some games require the SRAM be in sync with the game state or else weird shit happens. That happens because games can use the SRAM as a extension to RAM.
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64
Posts: 1140
Joined: Wed Jul 28, 2004 3:31 am

Re: Chrono Trigger Save Mayhem

Post by kode54 »

And while Chrono Trigger uses no such extensions, games which utilize the SuperFX or the SA-1 execute code from and work with data from the SRAM directly from the CPU inside the cartridge.
Post Reply