ZSNES for X64 linux (ubuntu)

Strictly for discussing ZSNES development and for submitting code. You can also join us on IRC at irc.freenode.net in #zsnes.
Please, no requests here.

Moderator: ZSNES Mods

Post Reply

ZSNES for X64 linux (ubuntu)

Post by WolfsMond »

Hello Community,

i'm new here and want so say hello and just ask my first question:

is there somewhere a "how to" for compiling the source in a x64 system (ubuntu 6.06 dapper drake) > or does is there some binaries? :)

i'm a linux newb, have done a lot of work with that terminal to get all stuff working (expect 2 little things, but i need zsnes first *g*).
thanks for help :)

well i have compiled it, but it wont start:
if i start it from terminal, the terminal gives out:

Illegal instruction

help me help me!!
i dont want to reinstall my linux again, it took me many hours to config it :-/
Posts: 361
Joined: Fri May 05, 2006 4:37 pm

Post by Firon »

ZSNES currently won't compile in 64-bit mode, nor do I think it'll even run on 64-bit OSes.

Post by WolfsMond »

that really makes me dissappointed :-(

it really sucks, its just because of that Evil Intel!

AMD released 64bit CPUs... what happend? Nothing... only Linux comes out with 64bit Support.
And then:
Intel releases 64bit CPU and suddently a Win64 bit came out, but that really sucked.

Somehow i think intel want to "exhaust" the 32bit CPUs, before they really make a 64 bit support with Microsoft.
the user dont know nothing about 64bit, they are just consumers and dump... only because of they dont know nothing *g*

that sucks that sucks!!!!!
ZSNES Developer
ZSNES Developer
Posts: 6747
Joined: Tue Dec 28, 2004 6:47 am

Post by Deathlike2 »

This problem has nothing to do with Intel...

For now, compile for a 32-bit target. It will still work on your 64-bit OS.
Continuing FF4 Research...
Posts: 603
Joined: Wed Jul 28, 2004 8:54 am

Post by Ichinisan »

Through most of the Beta test, XP 64-bit edition was branded specifically for AMD processors because there were no consumer 64-bit processors from Intel.
Need a new sig...
Posts: 84
Joined: Mon Dec 27, 2004 9:08 pm
Location: In A.D. 2101, war was beginning.

Post by bztunk »

I think a big fat red "zsnes won't compile on x64" label is needed on zsnes.com .
16:13 <Link`sAdventure> If I had my choice between Fedora and Windows, I'd pick windows.
ZSNES Developer
ZSNES Developer
Posts: 6747
Joined: Tue Dec 28, 2004 6:47 am

Post by Deathlike2 »

It needs a sticky... at least the Mac progress seems to be just about done...
Continuing FF4 Research...
New Member
Posts: 4
Joined: Mon Jun 26, 2006 2:25 am

Post by Chalnoth »

Well, I got zSNES to compile on my SuSE 10.1 64-bit distribution, but it won't run.

Here's what I did to get it to compile:
export CLFAGS=-m32
export CXXFLAGS=-m32

(Setting CFLAGS and CXXFLAGS each to -m32 tells the gnu compiler to output 32-bit code. NASM only supports 32-bit code, so this should be fine.)

It compiled fine this way, but I get the following error:
*** glibc detected *** ./zsnes: munmap_chunk(): invalid pointer: 0xffffdaa1 ***
...then follows a trace of the memory. It looks like this memory pointer is allocated to the stack:
ffffa000-ffffe000 rwxp ffffa000 00:00 0 [stack]

Now, this same exact error also shows up if I compile on a 32-bit machine and copy it over to my 64-bit machine. I'm at a loss as to the reason.
ZSNES Developer
ZSNES Developer
Posts: 3902
Joined: Tue Jul 27, 2004 10:54 pm
Location: Solar powered park bench

Post by Nach »

Chalnoth: Use SVN, v1.42 has too many invalid memory things going on.
May 9 2007 - NSRT 3.4, now with lots of hashing and even more accurate information! Go download it.
Insane Coding
New Member
Posts: 4
Joined: Mon Jun 26, 2006 2:25 am

Post by Chalnoth »

Excellent, works great now, thanks!

Suggestion: You could add the option -m32 as a default option when compiling ZSNES in Linux. It looks like this option doesn't do anything when compiling on a 32-bit machine, but would allow those of us with 64-bit distributions to compile and run zsnes painlessly.

Post by gcsimon »

Hi there,
I have the same/similar problem as described above (zsnes won't run on my SuSE 10.2 x64). But I think its more the way I compile zsnes. I'm using the exports described above also tried it with "linux32 ./configure". But any time I run "make" there are a bunch of "type cast pointer/integer" warnings and NASM plots stuff about "/usr/lib64/gcc/x86_64-suse-linux/4.1.2/../../../../x86_64-suse-linux/bin/ld: warning: i386 architecture of input file `linux/sdlintrf.o' is incompatible with i386:x86-64 output" (example). I fear I'm simply linking against the wrong libraries but I don't know how to fix it. As far as I know all 32bit libs are installed. The nvidia installer reported that it also installed 32bit opengl libs. There seems to be no "test program" for 32bit SDL (so "./configure --with-sdl-prefix=/usr/lib" fails)

Thanks in advanced.
Posts: 37
Joined: Thu Jan 27, 2005 7:28 pm

Post by RedDwarf »

gcsimon wrote:(zsnes won't run on my SuSE 10.2 x64)

For openSUSE 10.2 Guru repository always has the last ZSNES precompiled. Right now 1.51-2 doesn't works (if someone is interested, compile with "-D_FORTIFY_SOURCE=2" makes ZSNES 1.51 crash), but you can expect a 1.51-3 soon.

Post by some_guy »

http://ubuntuforums.org/showthread.php?t=432642 should help. That's how I got it working on my Ubuntu 64. I actually still have to patch the kernel to get my controllers working properly, but ZSNES itself works fine.

v1.51 from the znsnes about btw
New Member
Posts: 2
Joined: Sun Apr 29, 2007 4:09 pm

Re: ZSNES for X64 linux (ubuntu)

Post by fernandoc1 »

I've made a tutorial for people using Ubuntu 11.04 (Natty) 64 bit:

https://docs.google.com/document/pub?id ... ors83Cqq5g
Post Reply