View unanswered posts | View active topics It is currently Thu Jul 18, 2019 6:51 am



Reply to topic  [ 17 posts ] 
Zsnes 1.42 Crashes upon loading rom via netplay 
Author Message
New Member

Joined: Sat Jun 26, 2010 3:55 am
Posts: 9
Reply with quote
Post Zsnes 1.42 Crashes upon loading rom via netplay
Before I explain the problem, I play with one of my friends on donkey kong and netplay works PERFECTLY, save/load stats chat every works great.

However with this guy i'm trying to netplay with, we connect fine, we're in the chatroom (connection successful)

When I go to load up a rom (Any rom)

That we both have, zsnes simply freezes and shows the game drop down i.e load etc...

we're using hamachi, zsnes 1.42, basically the same stuff i'm using with my other friend and it works perfectly.

Only problem I had with my other friend which is similiar, if he maximized before we loaded the game our zsnes's would crash, however if he kept it windowed and Maximized it after the game loaded it was fine.

And yes I asked this new guy if he was doing the same (Maximizing before loading) and he said no.

Edit:

Just to clarify further, yes this guy can play games on zsnes fine, they load, they have sound he can play perfectly.

It is only when I try to load them when we are connected via netplay that our zsnes's crash. hope this helps.

So i'm really at a lost here of why I cannot net play with this guy when we're doing the exact same thing as when I play with my other friend and everything works perfectly.


Sat Jun 26, 2010 3:59 am
Profile
ZSNES Developer
ZSNES Developer

Joined: Tue Dec 28, 2004 6:47 am
Posts: 6747
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
My only guess is that there is a path issue with the other person's system. Make sure there are no spaces in the path to the files.

_________________
Continuing FF4 Research...


Sat Jun 26, 2010 8:38 am
Profile
New Member

Joined: Sat Jun 26, 2010 3:55 am
Posts: 9
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
Deathlike2 wrote:
My only guess is that there is a path issue with the other person's system. Make sure there are no spaces in the path to the files.


?

He can load the games fine on his own though. Its just when we try to netplay together it freezes


Sat Jun 26, 2010 7:44 pm
Profile
ZSNES Developer
ZSNES Developer

Joined: Tue Dec 28, 2004 6:47 am
Posts: 6747
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
Well, netplay was never "working" perfectly.. which is why netplay has to be totally redone in the first place (these issues should never crop up).

The only thing I can come up with is the game you're trying to play... some games that have save RAM (those that generate SRM file like most RPG games) can be problematic.

_________________
Continuing FF4 Research...


Sat Jun 26, 2010 11:51 pm
Profile
New Member

Joined: Sat Jun 26, 2010 3:55 am
Posts: 9
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
Deathlike2 wrote:
Well, netplay was never "working" perfectly.. which is why netplay has to be totally redone in the first place (these issues should never crop up).

The only thing I can come up with is the game you're trying to play... some games that have save RAM (those that generate SRM file like most RPG games) can be problematic.


we've tried many roms mate. same exact result for each.

Besides, why would the exact same rom work with my other friend but not this guy?

Net play does work perfectly with my other friend.

We have played and beaten SD3 secret of mana donkey kong country all without any hitches, desyncs or crashes.


Sun Jun 27, 2010 12:06 am
Profile
ZSNES Developer
ZSNES Developer

Joined: Tue Dec 28, 2004 6:47 am
Posts: 6747
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
Well, I have no idea as I said.

Just make sure the other guy has no spaces in his path (no folder can have a space in it). The primary reason for this is that spaces affect the poor parsing that the config file used to perform. Additionally, these issues can manifest themselves on a network game than locally... it's just how finicky it is.

_________________
Continuing FF4 Research...


Sun Jun 27, 2010 12:16 am
Profile
New Member

Joined: Sat Jun 26, 2010 3:55 am
Posts: 9
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
he didn't modify his path so, there would'nt be spaces, it is whatever it is as the default is.

but ty for your help

does anyone else have any idea what the issue could be?


Sun Jun 27, 2010 5:31 am
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
There is no default path ZSNES is installed to as there is no installer for ZSNES.

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Sun Jun 27, 2010 2:09 pm
Profile WWW
New Member

Joined: Sat Jun 26, 2010 3:55 am
Posts: 9
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
well i don't get what hes suggesting I do.

if you do everything the default way, extracting zsnes into a premade folder on your desktop, there isnt going to be spaces.

I also checked the paths in the config, no spaces there either.

So basically theres no spaces anywhere, if you do everything the default way, which is what he did, cause he installed zsnes exactly as I did.


Sun Jun 27, 2010 6:12 pm
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
Your friend whom your trying to play with (and is crashing for them) may have spaces in there path, that is what he was getting at. His login name may contain spaces.

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Sun Jun 27, 2010 6:29 pm
Profile WWW
New Member

Joined: Sat Jun 26, 2010 3:55 am
Posts: 9
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
franpa wrote:
Your friend whom your trying to play with (and is crashing for them) may have spaces in there path, that is what he was getting at. His login name may contain spaces.


His nickname? For netplay?


Sun Jun 27, 2010 7:00 pm
Profile
Gecko snack

Joined: Sun Aug 21, 2005 11:06 am
Posts: 2372
Location: Australia, QLD
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
No I mean his Windows Login. As his Desktop is positioned within his User folder. For instance if he uses Windows 7 and his user name was Adam Scott then the path to his desktop would be...

C:\Users\Adam Scott\Desktop

Creating a space in the path to anything on the desktop.

_________________
Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 8GB DDR3 1600 RAM | Gigabyte Geforce 760 4GB | Windows 10 Pro x64


Mon Jun 28, 2010 8:30 am
Profile WWW
Zealot
User avatar

Joined: Sat Jul 02, 2005 2:01 am
Posts: 1076
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
Don't forget that if he uses Windows XP, the desktop will be under C:\Documents and Settings\...\Desktop, which already has spaces. So he may have to put it under C:\zsnes\roms or something just to prevent the possibility of an issue.

_________________
Maybe these people were born without that part of their brain that lets you try different things to see if they work better. --Retsupurae


Mon Jun 28, 2010 10:58 am
Profile WWW
New Member

Joined: Sat Jun 26, 2010 3:55 am
Posts: 9
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
paulguy wrote:
Don't forget that if he uses Windows XP, the desktop will be under C:\Documents and Settings\...\Desktop, which already has spaces. So he may have to put it under C:\zsnes\roms or something just to prevent the possibility of an issue.


I have xp and mine is on the desktop... -_-

I know you are allt rying to help and all but everythings workin fine under the circumstances with me and I have everything wrong that you guys are listing and i play fine with 2 people now. no desyncs or load issues at all


Mon Jun 28, 2010 8:02 pm
Profile
New Member

Joined: Sun Jan 15, 2012 8:26 pm
Posts: 2
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
Hey guys,

just found that thread, though its quite old.

I've got some similar issue. More like 2 issues, one of them not that big of a deal though. Lemme explain:

I started playing online around 5 or 6 years ago, using ZSNEs 1.42 all the way on a Windows XP computer, arranging matches via zbattle.net. Had to configure my router (port forwarding) and my firefall back then to get it work. After I've done that, everything worked extremely well, no connection issues whatsoever.

Had some time out in 2010/2011. Got a new computer, Windows 7 64-Bit. Restarted playing online (massively), this time using Hamachi to make matches since it makes connecting much easier. From Day 1 on I could only maximize ZSNES when having Firefox in the backround. Not kidding. If Firefox isn't on, ZSNES crashes when maximizing. More than that, Firefox needs to run once, not twice (would make ZSNES crash as well). There's another guy in our community who has the exact same issue (running on Win7 64-Bit as well). But since its easy to deal with that, it's not really an issue anymore. Just some extremely weird bug I guess....

Bigger problem is: ZSNES crashes randomly when loading a rom after having connected. Means, I can start server/connect to server with no problems at all, talk to the other player fine. But when loading a rom (no matter if its me or him that loads it), ZSNES sometimes just loads it fine, sometimes crashes (sometimes infinite times in a row, but then a few hours later it does it perfectly fine). Since we are some pretty big communitiy and do tournaments, I withnessed this bug with (guessing) ~ 50 different guys, having this issue with all of them - sometimes. So its definately on my side.

Tried everything, starting ZSNES/hamachi with admin rights, compatibility mode, forwarding ports (though it shouldn't be a need for that when using Hamachi), creating exception rules for Firewall, re"installing" ZSNES.... everything you can imagine I guess. Nothing worked. Any new knowledge about this?

Thx for helping!

Greets Abzug86


Sun Jan 15, 2012 8:42 pm
Profile
New Member

Joined: Sun Jan 15, 2012 8:26 pm
Posts: 2
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
Oh wow, thats what I call a usefull and frequented board.


Sun Jan 22, 2012 5:52 pm
Profile
Official tech support dood

Joined: Wed Jan 25, 2006 7:57 am
Posts: 2081
Reply with quote
Post Re: Zsnes 1.42 Crashes upon loading rom via netplay
...or maybe nobody has any useful info for you. There's likely a background app or service that's causing the issue; trial-and-error is you best hope of isolating what it is.

_________________
Why yes, my shift key *IS* broken.


Sun Jan 22, 2012 9:46 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 17 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software.